Il file zip specificato non contiene una libreria valida

Sto tentendo di installe nell’ IDE 1.8.10 di Arduino delle librerie per gestire un sensore Sharp GP2Y0A… ma non riconosce nessuno dei due zip come libreria valida.
Ci sono alternative o altre soòuzioni?
I file zip sono quelli allegati.

Saluti

Lello

Arduino-GP2Y0A21YK-library-master.zip (199 KB)

Questa è la seconda libreria.
Anche lei non viene riconosciuta.
Non riesco a caricarla, è troppo lunga e mi da errore.
Saluti

Lello

ciao...penso che il problema (della prima libreria) è per com'è ordinato il file zip...nel senso che subito sotto allo zip non ci sono le classiche cartelle: example, src, utility etc...ma altre sotto cartelle

se hai altri zip di librerie riconosciute guarda come sono ordinate e fa lo stesso.

Ok!
Adesso guardo e correggo.
Saluyi

Lello

LelloGi:
Questa è la seconda libreria.
Anche lei non viene riconosciuta.
Non riesco a caricarla, è troppo lunga e mi da errore.

Ma non caricare l'intera libreria, riporta solo il link al repository su GitHub.

ORSO2001:
ciao...penso che il problema (della prima libreria) è per com'è ordinato il file zip...nel senso che subito sotto allo zip non ci sono le classiche cartelle: example, src, utility etc...ma altre sotto cartelle

Stavo per scriverlo anche io, penso sia questo il problema.

@LelloGi ti basta creare una cartella "src" e spostaci dentro tutti i file *.h e *.cpp.
Poi segnalalo all'autore su GitHub.