ILI9486 TFT strange behavior

Hello,

I am using a 3.5"TFT screen in one of my projects, connected via a custom PCB to a Nano Every. I wanted to build a copy of the project and ordered a new screen for the second unit. However, the screen I received has some evident issues: colors are washed out (black is gray-ish, red is almost impossible to see) and do not correspond to the other TFT's colors. There is also some ghosting under text and other colors, it looks like a "waterfall" coming down form what's drawn on the screen.

I have tried the new screen by plugging it directly in a Uno board and running both the calibration script and graphics test. They run correctly, but the colors displayed are terrible. Keeping the same code in the Arduino and switching screen solves the issue, so I am pretty sure the issue is correlated to the screen itself and not to the configuration.
Attached you can find some photos of the washed out colors and the calibration serial results, ran by plugging the screen in the Uno: as you can see it is recognized as ILI9486, just as the other screen (but it doesn't work).

Is the screen faulty? Should I send it back? It also has a strange white foam between the blue PCB and the screen itself, wich the other wroking screen doesn't have. This means there is a bigger gap between the screen and the PCB. This is where I bought it from: https://www.amazon.it/gp/product/B07SSYSWM1/

Any help is appreciated.
Thanks in advance :slight_smile:

I would send it back.

The Display in your link normally works 100%.

The Display in your photos is bad. Ask for a refund.

The bare TFT panel is attached to the pcb with some double-sided sticky tape. Foam tape is good.

David.

Thank you very much, I am sending it back.

Before you send it back, plug it into a Uno, Mega2560, Zero, Due, ...

If you get the same bad picture it is certain that the screen is bad.

Otherwise, it tries to display the correct pixels.
And the Touch Calibration is ok.

Most 3.5 inch Blue Shields have the Touch pins on 8, 9, A2, A3
You have them on 6, 7, A1, A2 which is common on the Red 2.4 inch Shields

David.

I tried it on the Uno and on the Every with my custom PCB. Both were having the same issue, so I sent it back.
Other than the image issue, touch calibration worked on the Uno but then with the Every it wasn’t registering input as expected.

This topic was automatically closed after 43 days. New replies are no longer allowed.