independent running code with 6DOF shield

Hi everyone,

I'm working on a robot balance project. I use an arduino UNO with the 6DOF shield from DFRobot (http://www.dfrobot.com/wiki/index.php/6_Dof_Shield_(DFR0209)). I just use accelerometer and gyroscope and this shield. My question is :

I programmed my code without problem, actually it works when I kept my USB connection. But when I want to use my board without USB connection it doesn't work. Is there a protocol issue or something like that?

Despite, I put the arduino example "Blink" on my board it is exactly the same problem. It works without the shield and doesn't work with.

Thank you very much for your help,

Jeremy ;)

But when I want to use my board without USB connection it doesn't work.

Presumably you have another power source plugged in?

Are you using Serial to talk to the shield?

How about you post the code.

As for the blink program, I can't think why the shield would affect that.


Rob

Thank you for your quick answer

I plugged a 9V; 1000mA power supply.

I don't use Serial to talk to the shield but I am trying to running the blink program with the shield for the moment and if it works I will try my other program. Because I don't understand why the shield has an influence on the blink program.

I've just looked at the schematics for that shield and I can see no reason it would affect a blink sketch, I suggest you ask on the DFRobot forum.


Rob

Thank you for your help.

I found a solution. Actually, I use my cell phone sector adapter to put the USB cable and it works.