Inserire immagini Arduino Ethernet shield

puoi andare a capo... per rendere tutto più leggibile .

Stazione meteorologica
LUX

MIN

MAX

TEMP C°

MIN

MAX

LED Acceso Spento
VENTOLA

Io ho questo codice, prima di ogni riga devo mettere il print.client? Io l'ho inserito tutto su una riga, ma non mi carica la pagina html.

Ci ho lavorato un paio di mesetti fa.. Metti tutto nel compilatore di arduino... e vedi di che "colore" ti appaiono le scritte.. dovrebbe essere tutto in blu all'interno del print.. Cmq attento ai doppi apici ".. mi sembra che quando ci smanettavo io erano quelli il problema... li devi sostituire con quello singolo '

Provaci.. Se non riesci come ho un po di tempo ritrovo quello che ho scritto io e ti faccio sapere sicuro..

Grazie mille :) e per inserire un'immagine?

io uso un dominio esterno per mettere le immagini e poi metto il link a quel dominio come un normale link a un'immagine nello sketh di arduino..

Altrimenti se ti vuoi complicare la vita puoi usare la microsd che puoi usare con l'eth shield... Ma li la cosa si fa seria.. e lunga.. e ci devi sbattere la testa un po :D

accidenti non esistono altri modi?? uffi io non ho idea di come si usi la sd

il codice html per l'immagine è riguardo ai doppi apici per non sostituirli bata mettere un carattere di escape tipo:

client.println("questa \"cosa\" funziona senza problemi");

ok ho capito il percorso ma dove metto l'immagine in arduino senza sd? non si può? perchè utilizzo un immagine di pochi kb per farli stare nella memoria interna arduino però non sò come inserirla in arduino e che percorso utilizzare

riassumendo

client.println("background-color:#090;"); client.println("}"); client.println("-->"); client.println(""); client.println(""); . . .

client.println(""); client.println(" Stazione meteorologica");

in quest ultima riga, può darmi problemi? Io modifico il codice in questo modo e lo rimetto in arduino e vi sò dire se mi mostrerà questa cavolo di tabella o no.

pigio: client.println(" Stazione meteorologica");

Nooooo!!! Il carattere di escape è "\" e non "/" !!!

mah.. non capisco perchè complicarsi la vita con i caratteri di escape..

Prendi un editor di testo tipo notepad++, incolla il codice e seleziona il doppio apice ".. dopodichè usa il comando per sostituire tutti gli " con ' e sei apposto in 10 secondi..

Cmq la soluzione piu immediata per l'immagine è caricarla su un dominio e richiamarla con un link...

pigio: Sto cercando di inserire un immagine in una pagina html creata da un web server arduino. il problema è che non ho idea di come si faccia, vorrei evitare l'utilizzo della scheda sd perchè non sono capace di utilizzarla.

le immagini sono troppo grosse per arduino. usa la sd o mettile su un server web esterno.

anche le immagini di 10kb?? comunque proverò a cercare un immagine in internet e ci copio il link allora ;) comunque alla fine ho sostituito gli " con ' e sembra funzionare!!! vi teno aggiornati ;) sul mio progetto ho una fotoresistenza, un led che si accende quando è buio, un LM35 e successivamente devo mettere una stazione che misura la direzione e la velocità del vento, un sensore di prossimità ad infrarosso che mi servirà a fare qualcosa che deciderò più avanti e una ventola che si accende quando è caldo :) Non sò che altro aggiungere. Il tutto verrà visualizzato in una pagina web attraverso una connessione internet da un cellulare

ethernet--->internet---->internet--->cellulare

dr4gone: Prendi un editor di testo tipo notepad++, incolla il codice e seleziona il doppio apice ".. dopodichè usa il comando per sostituire tutti gli " con ' e sei apposto in 10 secondi..

Questo è un pessimo suggerimento!

Il nostro amico vuol fare una cosa semplice, vuole scrivere la seguente stringa:

Stazione meteorologica

Se vuole usare il client.println() allora deve eseguire l'escape del carattere " (virgolette). Il modo più semplice per farlo è di usare il carattere di escape \ prima delle virgolette.

Ma usare le virgolette singole al posto delle doppie è assolutamente fuori luogo. Certo, molti browser sono abbastanza tolleranti da concederti questo errore ma è pur sempre un errore.

Mi par di vedere ancora i miei vecchi colleghi che per per scrivere la à (la lettera a accentata) al computer scrivevano a' (cioè una a seguita da un apostrofo). Pessime abitudini!!!

Io ho messo le ' al posto delle " comunque provvedo a cambiare allora!! Forse ho un problema coi link delle immagini, vi saprò dire! a presto! e grazie!

robitabu:

dr4gone: Prendi un editor di testo tipo notepad++, incolla il codice e seleziona il doppio apice ".. dopodichè usa il comando per sostituire tutti gli " con ' e sei apposto in 10 secondi..

Questo è un pessimo suggerimento!

Potrebbe anche essere un pessimo suggerimento per fare un sito o un programma stabile come si deve... Ma visto che è il primo progettino che fa, non riusciva a risolvere con l'escape, e ancora è in fase di test, per non farlo scoraggiare gli ho indicato la via più semplice e sbrigativa.. Infatti come noti è stato in grado di risolvere i suoi problemi immediatamente, e a farlo funzionare..

Poi che sia un metodo "sbagliato" questo è un altro paio di maniche..

Come dico sempre.. l'importante è che funzioni, per le ottimizzazioni c'è sempre tempo :grin:

a livello di web non cambia molto ma come programmazione " viene indicato come char e ' come string, o era qualcosa di simile, comunque non sono la stessa cosa ;)

sia che metti le immagini su arduino o sulla sd(basta caricare le immagini collegando la sd al pc...) devi poi prevedere nel codice che quando il client richiede l'immagine gliela invii, mi pare che si invia il binario. Se ti interessa dò un'occhiata

se usi la flash di arduino magari 10k ci sta(proprio non ricordo le dimensioni), dipende anche da che atmega stai utilizzando...

edit:

superlol: a livello di web non cambia molto ma come programmazione " viene indicato come char e ' come string, o era qualcosa di simile, comunque non sono la stessa cosa ;)

giusto, però credo che sia nell'html che in alcuni linguaggi di programmazione le ' sono equivalenti a ", proprio per evitare troppi sbatti con i caratteri di escape... però questa info prendila con le pinze

le immagini le carichi su http:\imageshack.us

una volta caricata il sistema ti darà un collegamento da inserire nell'Arduino

ok! qualcuno sa come connettersi da un altro computer al mio via internet? arduino ha indirizzo statico 192.168.1.30 nella mia rete, porta 8080 (perchè la 80 è bloccata dall isp) sono andato nelle impostazioni del router ed ho fatto il port forwarding indirizzo 192.168.1.30 inizio porta 8080 fine porta 8080.

è corretto? e adesso cosa dovrei fare?

ho creato una nuova discussione perchè stavo andando off topic :)