INSTALLATION CH340 MEGA2560

bonjour

j'ai acheté une carte arduino mega 2560 ch340. mais impossible de televerser un programme dessus.

Salut,

La carte n'est pas reconnu dans windows, il faut installer le driver pour le chipset ch340.

non j'ai une uno avec le drivers, j'ai bataillé au debut mais j'ai le drivers . je ne peux pas téléverser un programme time out .

Tu a bien changer le type de carte ainsi que le port série dans l'IDE.

port serie ? il'na pas changer
com4 selectionner
type de carte arduino /genuino mega 2560
dois je faire autre chose ..

Il y a une chose étrange dans le fait que le port serie soit le même que pour la uno, car sur mon PC, j'ai un port serie différents suivant que je branche une Uno ou une mega, dans le gestionnaire de windows la mega est elle bien reconnu et avec quel port serie.

@+

j'ai ce message
sous XP
USB serial CH340. si je branche les 2 cartes 2 port differents. mais meme nom de pilote.

j'ai ca
avrdude: stk500v2_ReceiveMessage(): timeout

j'ai un port serie différents suivant que je branche une Uno ou une mega,

Ce que tu indiques est-il obtenu avec 2 cartes équipées d'atmega16U2 ou avec des CH340G ?
Le comportement des deux circuits est peut-être différent.

Info : avec la dernière carte que j'ai acheté :

  • Un " $lsusb " (OS=Linux) indique ".QinHeng Electronics HL-340 USB-Serial adapter"
  • Un" $ dmesg donne : ch341-uart converter now attached to ttyUSB0

68tjs:
Ce que tu indiques est-il obtenu avec 2 cartes équipées d'atmega16U2 ou avec des CH340G ?
Le comportement des deux circuits est peut-être différent.

Info : avec la dernière carte que j'ai acheté :

  • Un " $lsusb " (OS=Linux) indique ".QinHeng Electronics HL-340 USB-Serial adapter"
  • Un" $ dmesg donne : ch341-uart converter now attached to ttyUSB0

La mega possède un 16U2, pour la Uno je ne l'est pas à la maison mais au Taf, mais ces une version officiel Italy.

non CH340G pour les 2 cartes
carte de chine ( elle a traine et donc pas payer heureusement)

ATmega2560-16AU CH340G MEGA 2560 R3 Board

Donc si je résume
@Hameau : si c'est une carte officielle c'est un atmega16U2.
Aucune des deux arduinos n'utilise le ch340G (contrats avec Atmel obligent)

Cartes "Hameau" Cartes "Esso1"
Uno = atmega 16U2 Uno = CH340G
Mega = atmega 16U2 Mega = CH340G

Je ne peux comparer qu'à Linux : un atmega16U2 est vu comme un /dev/ttyACMX c'est à dire (si je ne me goure pas) une unité de stockage et un ch340G est vu comme un /dev/ttyUSBX c'est à dire (toujours si je ne me goure pas) un périphérique USB.
Un comportement différent de Windows avec les deux circuits est possible et probable .

Mais cela ne résoud pas les ennuis d' "esso1" .

Un examen visuel (de préférence avec une loupe ) ne révèle t-il pas de mauvaises soudures ?

merci a vous, je pense que la carte a un soucis, mais je ne sais pas... bref vu que je n'ai pas payer ( remboursement livraison trop longue) , je ne vais pas pousser plus loin.
j'en avais commander une autre ailleurs, j'avais plus peur de ne pas faire comme il faut.

j suis a la bourre sur le coffré elec donc pas de soucis d'attendre. et je continue de regarder certain truc avec l'arduino.

vous etes en tout cas super réactif et sympa..
un grand merci a vous .