Installe Arduino ISP sur windows

Bonjour,

Dans le cadre d'une activité pédagogique, j'ai plusieurs robots Arduino pour lesquels tout fonctionne bien (IDe 1.6.5 ou 1.7.7).

Cependant, j'ai aussi des ISP R3 (http://www.arduino.org/products/7-arduino-accessories/arduino-isp).

Je le relie au câble USB, que je relie au PC. Windows me détecte bien un ARDUINOISP mais ne peux pas installer de drivers, et cela sur plusieur ordinateurs différents (marque, modele et OS).

J'ai bien tenté d'installer les drivers (https://www.arduino.cc/en/Guide/ArduinoISP) mais Windows n'en veux pas. Selon lui il ne correspondent pas au périphérique detecté.

Une piste ?

merci d'avance

mgrisel: Cependant, j'ai aussi des ISP R3 (http://www.arduino.org/products/7-arduino-accessories/arduino-isp).

Je le relie au câble USB, que je relie au PC. Windows me détecte bien un ARDUINOISP mais ne peux pas installer de drivers, et cela sur plusieur ordinateurs différents (marque, modele et OS).

J'ai bien tenté d'installer les drivers (https://www.arduino.cc/en/Guide/ArduinoISP) mais Windows n'en veux pas. Selon lui il ne correspondent pas au périphérique detecté.

Une piste ?

merci d'avance

bonjour je ne connais pas , mais il semble que ce soit juste un simple programmateur ISP basé sur V-USB sous AVRDUDE il faut choisir USB et pas chercher un port com

Mon problème viens que le gestionnaire de périphérique windows m'indique que le périphérique ne fonctionne pas correctement, donc que cet ISP par conséquent ne peut pas être listé dans les ports de l'IDE.

Pour bien expliquer, je branche le périphérique sur le PC, le PC détecte la connexion d'un périphérique, trouve qu'il se nomme ArduinoISP, tente d'installer des drivers mais échoue. Si je tente d'installer à la main, il m'indique en localisant le répertoire des drivers, il échoue aussi.

J'ai tenté encore plus à l'ancienne, en choisissant périphérique de type port et LTP, et en parcourrant pour trouver le fichier .inf. Il me demande un arduinoISP.inf, je le trouve et me dis que mon périphérique ne correspond pas à mon driver.

bref je tourne en rond

Aucune piste ?

Bonjour,

J'avance un peu.

J'avais des ISP qui fonctionnaient bien.

Il existe une différence entre ceux qui sont détectés et les autres

Celle-ci est sur le dos

|500x375

Ceux dont je peux installer les drivers ont sur leur dos l'adresse www.arduino.CC ceux non arduino.org comme sur l'image ....

La conséquence : les arduino.cc sont reconnus comme libusb dans windows les arduino.org ArduinoISP

Un autre lien pour les drivers du coup ?

Bonjour,

Je pense qu’il faut regarder sur arduino.org
Sur cette page tu as un lien pour télécharger les drivers.

Bonjour oui ils ont été mis il y a peu car ils n'étaient pas présents lorsque j'ai crée le topic

Est ce que ça fonctionne avec ces drivers? Si c'est le cas c'est franchement pénible que l'arduino ISP italien et l'arduino ISP américain ne soient pas compatibles.