Installed add on throws Java method missing error when run

Hi. I'm noob, just poke about problems. :slight_smile:

I am working through the book "Junk Box Arduino", and we need to install something on the tools menu, and run it. Installs fine from the sketch folder, but when I run it from the menu, I get this error:

Hello from Burn_Preflight
Exception in thread "AWT-EventQueue-0" java.lang.NoSuchMethodError: processing.app.helpers.StringReplacer.formatAndSplit(Ljava/lang/String;Ljava/util/Map;Z)[Ljava/lang/String;
at com.burn_preflight.Burn_Preflight.gencommand(Unknown Source)
at com.burn_preflight.Burn_Preflight.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Been a while since I messed with Java at all, any idea what I'm missing here? Thanks in advance for any assistance. :slight_smile:

I gave it a try but didn't even get a menu item for the tool.

I notice that it's an older project. There was a breaking change to the API of the Arduino IDE that the tools use, as mentioned here:

It's mentioned at the link above that happened in Arduino IDE 1.6.12 release. So you could try an older IDE version. The Burn_Preflight project readme says:
https://github.com/jrstrick/Bootloader_Burn_Preflight_Check#readme

The pre-build Burn Preflight Tool was built against Arduino 1.6.5, and is known to run properly with Arduino 1.6.7.

Old IDE versions available for download here:
https://www.arduino.cc/en/Main/OldSoftwareReleases#1.5.x

1 Like

Awesome, worked like a charm. Thanks so much for the assist! :slight_smile:

You're welcome. I'm glad to hear it's working.

1 Like