installed new version, with problems, and cannot revert back. Help pls

Hi,

Yesterday I have downloaded the new version, but it could not even install, was having problems with some missing files or whatever. I did not bother much about it for now, as I have to work on a project tomorrow. So I re installed the previous version, which worked just fine before I had uninstalled it.

My problem now is that the IDE cannot upload to the board. I have done what i found in forums, and re installed the drivers. Now, in my Device Manager, I can see it as UNO, but the IDE cannot connect to it. It is giving me this result.

Arduino: 1.6.0 (Windows 8), Board: "Arduino Uno"

avrdude: ser_open(): can't open device "\.\COM4": The system cannot find the file specified.

O.K. SOLVED. ;D ;D

Can you please change your topic title to [solved] ? Helps others by not scaring them ;)

o.k sorry. I still dont know how things work out here. :)

however, the new version, did not install. It kept on saying missing files. I tried to download again, and same result.