Installer

I Can't running the installer

Hi @Ammar1972. I'm sorry to hear you're having a problem running the installer. If you'll provide some additional information, it might be helpful to the people looking into this issue.

Which operating system are you using?

Please provide a detailed description of the exact problem you're having while trying to run the installer, including the full and exact text of any error messages you might be getting.

I'm having the same problem. Running Mac Catalina 10.15.2. when trying to install the installer, I get:

“ArduinoCreateAgent-1.1-osx-installer-CI.app” can’t be opened because Apple cannot check it for malicious software.

Help!

Hi @HybridmanWV. The workaround to that issue is described here: https://forum.arduino.cc/index.php?topic=658826.msg4439237#msg4439237

ubidefeo: Mac OS Catalina has a more aggressive check on how an application is registered with Apple (Notarised). We're in the process of finalising this process for good, but right now you'll have to use a work-around to install.

Right click (or CTRL + Click) on the icon and select "Open". This should ask you if you are sure you want to install. Agree and the process will continue.

Sorry for the inconvenience, but Apple sometimes tries (for good reason) to make things harder to protect non advanced users.

If it doesn't work out let me know and I'll test further :)

u.

Hi @HybridmanWV I'm happy to report that a new notarized version of Arduino Create Agent (1.1.251) has now been released. This will no longer require the workaround I described above. You can get it here: https://github.com/arduino/arduino-create-agent#installation