Installing Arduino Create Plugin on Mac OS X 10.4.11

Hello

I am using an old Power PC G5 and the installer would not even open...

Is it compatible with such an old OS? Any solution otherwise?

Many thanks,

MeltingProd

Most of the older OS including windows up to and inc VISTA / XP are not supported.

If you really want to use CREATE I would suggest a newer OS.
Failing that there is always the desktop IDE.