Installing Board versions later than 1.1.2 fails and renders unusable

I had a lot of trouble when first starting to get going with the Nano 33 BLE Sense, because I was unable to install the board in the Boards Manager, which kept saying "CRC doesn't match, file is corrupted". I tried various things to fix it, reinstalling, rebooting, deleting the 'staging' files from AppData - nothing worked.

I eventually managed to circumvent the problem by using an older version of the Arduino software and sticking with version 1.1.2 of the "Arduino nRF528x Boards (Mbed OS)" board driver in the Boards Manager. I was then able to program the board and do things with the sensors etc with no apparent issues. So far, so just-about-acceptable.

It now transpires than in order to use the UART function (as one would use SoftwareSerial on a standard Arduino Nano), which I need for my project, it is essential to upgrade to version 1.1.3 or higher.

This puts me squarely back in the same position where I started, except this time I can't work around it by installing old versions. I have searched for solutions to no avail. I can't actually do anything else with the board now, since a failed install in the boards manager also appears to break the existing installation. Details:

  • 64-bit Windows 10 machine, a few months old
  • Arduino software version 1.8.9 (although I experienced this problem with later versions too, hence why I specifically installed an older version to get around it)
  • Board is an Arduino Nano 33 BLE Sense
  • Error occurs when trying to update "Arduino nRF528x Boards (Mbed OS)" in Boards Manager to version 1.1.4 (or install it in the first place, in the case of a clean install of the Arduino software)
  • Error message is as follows: CRC doesn't match, file is corrupted. It may be a temporary problem, please try again later. java.lang.RuntimeException: java.lang.Exception: CRC doesn't match, file is corrupted. It may be a temporary problem, please try again later. at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:175) at java.lang.Thread.run(Thread.java:748) Caused by: java.lang.Exception: CRC doesn't match, file is corrupted. It may be a temporary problem, please try again later. at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:95) at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:55) at cc.arduino.contributions.packages.ContributionInstaller.install(ContributionInstaller.java:101) at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:172) ... 1 more

I have already tried reinstallation, different software versions, and clearing the 'staging' folder in AppData\Local\Arduino15. I'd be very grateful for any suggestions on how to solve this :)

I just did a clean installation of 1.1.4 on a Windows machine, so it isn't a universal problem.

Some logging functionality was added in Arduino IDE 1.8.10 specifically to help troubleshoot this type of issue. Since using 1.8.9 isn't doing you any good, I'd recommend going back to using Arduino IDE 1.8.12. After that, try this:

  • Delete AppData\Local\Arduino15\logs (so we can start from a fresh log).
  • Start the Arduino IDE.
  • Attempt an installation of Arduino nRF528x Boards (Mbed OS).
  • After the installation fails, open AppData\Local\Arduino15\logs\application.log in a text editor.
  • Copy and paste the contents of the file in a reply here. Please use code tags ( button on the forum toolbar).

If the log text exceeds the forum's 9000 character limit, you can post application.log as an attachment. If you click the "Reply" button, you'll see an "Attachments and other settings" link that will allow you to make an attachment. The forum software might disallow the .log file extension. If so, rename the file so it has a .txt extension, which the forum will allow.