Installing BOTH Megacore and Mightycore

Arduino 1.6.5 used.

Is it possible to install BOTH cores? It seem that if I install the Megacore then the Mightycore is no longer there and viceversa.

Can more than 1 core be installed at the same time?

Did you do a Boards Manager installation or a Manual installation of the cores?

samperi:
is no longer there

What do you mean by "no longer there"? It doesn't show up in the Tools > Board menu?

I did a boards manager installation but if I install one pack then the board page shows the chip for that pack, trying to add another pack the same way gets rid of the above and I can only see the chips for the new pack.

By the way I also tried doing a change to the preferences file, at the moment I have both URLs separated by comma:

boardsmanager.additional.urls=https://mcudude.github.io/MegaCore/package_MCUdude_MegaCore_index.json, https://mcudude.github.io/MegaCore/package_MCUdude_MightyCore_index.json

maybe it's not correctly done.

Both packs are installed (hmm can't just add screen shot here)

It doesn't show up in the Tools > Board menu?

correct, I either see the mega chips or the mighty chips.

samperi:
By the way I also tried doing a change to the preferences file, at the moment I have both URLs separated by comma:

boardsmanager.additional.urls=https://mcudude.github.io/MegaCore/package_MCUdude_MegaCore_index.json, https://mcudude.github.io/MegaCore/package_MCUdude_MightyCore_index.json

That's correct, though it's easier to just do File > Preferences > Additional Boards Manager URLs. You do need to leave both URLs in that field. If you remove a URL then those boards no longer appear under Tools > Board.

So try the following:

  • With both URLs in the additional urls field, Open Tools > Board > Boards Manager
  • Check to be sure both packages are shown as installed
  • Close Boards Manager
  • Check Tools > Board to see if the boards for both packages appear

It works for me.

:frowning: it was a loose nut behind the keyboard..... :confused:

I had the wrong URL spelling for the 2nd URL https://mcudude.github.io/**MegaCore**/package_MCUdude_/**MightyCore**_index.json

it must have happened when I was trying things out yesterday. All working well and the check is in the mail.

Thank you very much.