Installing Core Spartan Controller Board from Modern Robotics in Arduino IDE 1.8

I am trying to install a new board from Modern Robotics called a “Core Spartan Controller” into the IDE 1.8.3. I am using the guide recommended by Modern Robotics found here. After I complete step 2 on page 10 which adds an additional url for the board manager and attempt to search for the “Spartan” boards, the boards manager window basically freezes and I get the attached errors printed in output window of the IDE.

Any suggestions?

Spartan_Board_Error.txt (58.6 KB)

If you are on Windows 10, install the Arduino from the ZIP file not from Windows app store.

I had previously used the .exe to do the install instead of the app. At any rate, I uninstalled and downloaded the zip. Opened from the extracted folder and I am still getting the same result.

The cause of the error is the JSON file is missing the tools field. I have posted a fixed version of the file that will allow you to install the hardware package. This file is identical to the official version except for the addition of the empty tools field.

To use it you should follow the instructions in section 4.2 of the pdf file you posted above except change the URL: http://modernroboticsinc.com/Content/Images/uploaded/Spartan/ArduinoLibrary/package_CORE_SUPPORT_index.json to: https://gist.githubusercontent.com/per1234/4acbe92f6d185b5b6652b8a2e6cc4943/raw/c019e73ed48114e233bd572d1ccaaf668ca6f253/package_CORE_SUPPORT_index.json

I have reported this issue including the fixed file to Modern Robotics technical support. The issue of the less than graceful handling of this issue has also been reported to the Arduino developers: https://github.com/arduino/Arduino/issues/5351

You should be aware that by using my fixed version of the URL you will not receive notifications of new releases of the hardware core Modern Robotics may make. So once the problem has been fixed by Modern Robotics I recommend that you change back to using their URL, which can be done by simply changing the URL in your File > Preferences.

That did the trick. Thanks!

Still no action from the clowns at Modern Robotics Inc. and no response to my email. This is a super easy 30 second fix of a problem that would never have happened in the first place if they had followed the published specification rather than copy and pasting from some other hardware package. I provided them the fixed file, all they need to do is upload it to their server.

I would strongly recommend against anyone purchasing their products as this problem indicates they do no ongoing testing of their products and their tech support sucks.