Intensidad de los leds conectados a Arduino UNO

Buena tardes, lo primero presentarme ya que soy nuevo en este foro y en mundillo arduino.

Os pongo en situación. Tengo en mente hacer un proyecto por el cual, según los valores de un acelerometro o un sensor de sonido haga funcionar un motor.

Haciendo primero pruebas con el SENSOR DE SONIDO, hice un circuito con 4 LEDs que según el volumen se encendían en linea de 1 a 4 leds (como los displays de los equipos de música)

Mientras me llegaba el controlador del motor DC me vine arriba y pensé hacer lo mismo pero con 9 LEDs para que fuese mas vistoso.

Y aquí viene mi problema / duda. Unos leds brillan con mas intensidad que otros y no entiendo porque pasa(los he cambiado de posición y no es cosa de los LEDS sino de las salidas)

Alguna ayuda de como arreglarlo? Alguna razón de por que pasa?

Un saludo a todos espero que esto no se haya preguntado ya pero he estado mirando y no lo veo.

Muchas gracias.

Como has conectado los leds? Directo a los pines del Arduino? MAL Deben usarse resistencias. No dices que Arduino usas. SUpongo un UNO entonces deberías usar 330 a 470 ohms.

pon el codigo que estas utilizando y el esquema de como lo estas conectando recuerda leer las normas del foro para saber como se debe de poner correctamente el codigo y las imagenes.

surbyte: Como has conectado los leds? Directo a los pines del Arduino? MAL Deben usarse resistencias. No dices que Arduino usas. SUpongo un UNO entonces deberías usar 330 a 470 ohms.

Si, como has adivinado no he usado ninguna resistencia. Pero no entiendo si le pongo a todos los leds las mismas resistencias el resultado debería ser parecido al que ya he obtenido.no? porque el problema no es que se enciendan o que se quemen, sino que unos brillan a diferente inensidad que otros. perdona mi ignorancia a mi la electrónica de la facultad como que se me ha olvidado toda.

firius2010: pon el codigo que estas utilizando y el esquema de como lo estas conectando recuerda leer las normas del foro para saber como se debe de poner correctamente el codigo y las imagenes.

Discúlpame estoy fuera de casa ahora en cuanto llegue los subo. Algún sito donde pode hacer esquemas? sino os subo una foto,

debes de usar la resistencia como te comenta Surbyte de lo contrario corres el riesgo de quemar o el pin del arduino o el LED y le estarias demandando mucha corriente al pin al no limitarla con la resistencia, considera que la maxima corriente por pin es de 40 mA

firius2010: debes de usar la resistencia como te comenta Surbyte de lo contrario corres el riesgo de quemar o el pin del arduino o el LED y le estarias demandando mucha corriente al pin al no limitarla con la resistencia, considera que la maxima corriente por pin es de 40 mA

Entonces es posible que los primeros pines se les este demandando mas de 40mA y por eso a los últimos no les llega suficiente?

Entiendo de tu respuesta que todos los pines digitales son iguales en cuanto a amperaje y voltaje , correcto?

Muchas gracias por la ayuda

arduino no puede entregar mas de 200mA por su pines I/O SUMADOS. Asi que eso está ocurriendo. De casualidad no se te ha quemado alguna salida. Hay que leer antes de hacer cosas. Vives en un mundo finito, o sea todo tiene límites y el arduino también.

Pues ya tengo las resistencias pedidas a ver si me llegan prontito.

Muchas gracias

Ya me ha llegado el controlador de motor (necesitare resistencias para esto tb?) asi seguire buscando dudas en el foro o preguntandoos. Sobre todo con el acelerometro, que lo veo mas complejo que el sensor de sonido.

Muchas gracias de nuevo