Interfaccia i2c

Ciao a tutti, ho acquistato l’interfaccia i2c in foto. Guardando alcune immagini in rete, mi sono accorto che i pin sulla mia interfaccia hanno l’ordine invertito. Se notate il pin vicino alla dicitura “led” è evidenziato; in tutte le immagini trovate in rete invece ad essere evidenziato è il pin opposto (vicino al GND). Per questo motivo ho pensato di saldare l’interfaccia sul display nel modo in cui vedete in foto e ho provato ad alimentare il tutto con un alimentatore; il display si accende. Ho pensato di chiedere a voi se il collegamento è corretto, visto che non vorrei danneggiare Arduino se i collegamenti sono sbagliati. Spero di essere stato chiaro…
Grazie…

L'hai montata al contrario, il collegamento corretto è questo

Grazie... ma se noti nel tuo esempio il pin evidenziato è esattamente nella posizione opposta al mio. Come si spiega questa cosa? Anche perchè la retroilluminazione e il led "power" sulla scheda si accendono.

Ale_S ... l'hai montata al contrario ... :smiley: :smiley: :smiley:


Che qualche cosa si accenda è più che normale ... comunque arriva tensione su alcuni pin ... :wink:

Guglielmo

Ok, vedo se riesco a dissaldarla, altrimenti pazienza... prenderò un altro display, questa volta già con l'interfaccia!

Capita... soprattutto le prime volte. Chiudi il 3d rinominando il titolo con la dicitura [RISOLTO] all'inizio e non dimenticare i KARMA :smiley:

Puoi tagliere i pin tra le 2 Schede con un segetto per ferro e dopo puoi togliere la plastica dello strip e dissaldare i pin uno a uno.
Questo é il modo piú semplice per dissaldare le schede.

Ciao Uwe