Interfacing with rope leak detector cable?

Hi everyone!

I am moving on to the next phase of my home environmental monitor project, and I am kind of at a loss how to accomplish this next part. I had purchased a Honeywell RWD41 leak detector from amazon a while back, which uses a leak detecting cable. I'd like to use the cable in conjunction with my Mega. However, I'm having a hard time figuring out how. When I trigger the sensor cable, I can't detect any changes with my multimeter; eg., resistance stays 0 ohms, diode checker doesn't show anything, etc.

Does anyone know how those things work and how to interface them with an arduino? Or where to start to figure it out?


well the manual does not seem to indicate that there is an existing way to read any signal from the device without hacking it about a bit.

First thing i would do is open it up and see what is there to work with.

Are you sure it is reading ZERO ohms and not open circuit ?

Cheers Pete.

I have no idea how they work, but my guess would be that it detects a conduction path between two electrodes when porous insulation between them becomes damp. You’d need to work out what sort of interface there was between the sensing cable and the control unit. If the sensor cable just plugs in directly I’d expect to find a change in resistance or capacitance of the cable when it was damp. If the cable includes any electronic components, you’d need to reverse engineer the output from that.

Well if you unit announces a leak by turning on a buzzer alarm you could tape a microphone sensor module to it and use it's output signal as the trigger to an arduino.

Cool, thanks :) I'll probably have to either find a way to interface the controller board with the arduino (microphone, etc.) because the design looks pretty proprietary; for example, the main IC is just marked "bows v2.01039 ge3", which I couldn't find a data sheet for.

Bainesbunch - it looks like it's actually open, not zero ohms, regardless of whether it's under water or dried out.

chrismyers81: Bainesbunch - it looks like it's actually open, not zero ohms, regardless of whether it's under water or dried out.

I suspect that there is subtle change in resistance or it would not work this is also supported by the fact that you can just add more of the sensor strips end to end according to the manual. Are you using a DMM if so set the resistance range to the mega and try again. in the very high range you should be able to see a change just be putting your fingers across the sensor tracks.

Cheers Pete.

Hmm, it's really weird. Even with the DMM on 2M ohms, it's still reading nothing. Well, mostly. I tried it a couple of times, and sometimes it would flash up to like 1.8M or 1.7M for a second, then go back to "OL" (the default when nothing's connected.) But most of the times, it wouldn't budge from "OL".

The rope sensor is stamped that it's made by RLE Technologies, but I didn't find a similar one on their website, and the ones on the website don't look like the one on the device either. On the device, the two black strands seem to be basically embedded in the plastic, rather than having some sort of jacket over the sensor wires; unfortunately, the ones on their website don't really tell anything about the product's characteristics :/ It definitely makes sense that it would be resistance, but it's not acting like it.

When I had the case open, I put my DMM on the leads, and about once a second, it would pulse about 4mV.

So, apparently it is resistance, but I'm curious.

Since it's got an RJ11 on the end, I grabbed a phone jack and hooked it up to an LED and battery (with a resistor for the LED of course.) When I stuck the sensor wire in a cup of water, the LED lit up.

So, I have my answer...just not sure why my DMM couldn't detect it with the resistance or diode checker parts :/

Well it may have nothing to do with it's resistance, but rather it's change of capacitance in the presence of moisture. The capacitance would then be used to measure a R/C time constant and alarm at a certain value.

Cool. A noob question for you - what all does the change in capacitance mean in this instance versus if it was just changing resistance?

I went ahead and hooked it up the Arduino, and it seems to work fine :) When I manually trigger it, it puts about 0v9 through to the analog pin (from a 5v source) so I'm able to trigger the alarm directly :)

Cool. A noob question for you - what all does the change in capacitance mean in this instance versus if it was just changing resistance?

Most simple sensors work by either changing it's resistance, or capacitance, or induction in presence of a change of the thing being sensed. That in turn determines what kind of circuit it has to interface with.

I know this was a long time ago, but i have also purchased the honeywell water leak cable and im trying to hook it up to my raspberry pi.

chrismyers81 - are yo able to give more information on how you hooked it up and got it to work?

the cable has 4 wires in it - I have no idea which to connect to which pin on the raspberry pi gpio....

Since I've had a couple of questions related to this, and I did the super annoying "does this work" without posting my follow-up afterwards...

All I did when I hooked it up is hook one end up to 5v, and the other to a GPIO on my Arduino (through a current-limiting resistor.) The code I'm using to read it is:

//Check for water leaks analogRead(leakPin); int leak = analogRead(leakPin); if (leak > 100) { masterAlarm = true; //sensAlarm if (!leakAlarm) { leakAlarm = true; Serial.print(leakPin); Serial.println(",x,1"); } } else { if (leakAlarm) { leakAlarm = false; Serial.print(leakPin); Serial.println(",x,0"); } }

It's worked perfectly fine ever since :)

Also, on mine, I only have two wires in the part of the sensor that plugs into the phone jack, so maybe there's either something different about the extension versions, or newer versions than what I have?

In case anyone else comes across this post (as I did) - here is what I'm seeing. I bought just the extension cable and plan to cut it into small lengths to use as leak sensors. The extension has 4 wires in the RJ11 phone jack: Black, white, red, black. When it's dry, none of them are connected to each other. I put one loop of the cable in water, put 5V on each of the lines and tested the others to see what I got. The red and white wires never register anything. With 5V on one of black wires, the other reads about 3.7V when wet and decreases quickly as the cable dries. This makes sense as it looks like only the black wires are in the other jacket of the cable.

So it looks like the correct hook up is to wire VCC (5V or 3.3V) to one of the black and connect the other one to an arduino pin. I tried a 10K pull down resistor - that pushes the voltage down to 1.3V but that might be just a function of using a multimeter - I'm not sure. I also tried putting one black wire to ground and then using a pull up resistor on the other side to 5V and testing that with a multi-meter but I couldn't get a very good reading from that.

One more note - it's important to use analogRead() on this. Using a 5V input source, analogRead() returns ~20-30 (out of 0-1023) when the cable is dry and any where from 100-255 when it's wet. That's not high enough to trigger a HIGH value on digitalRead() so this needs to be used with an analog pin (or with an external amplifier circuit).