Internet Access with ESP32 DEV Kit C V4

Hi there, I’m a bloody beginner and tried a small test sketch covid tracker from Github

The Wifi connect to my router was successful and I got an IP address. However I didn’t get a response from the worldometer web site.
The serial monitor showed me:
16:00:37.344 → ⸮⸮⸮⸮⸮⸮⸮⸮@⸮}R~ŘM)⸮`⸮@⸮⸮⸮Init TFT …
16:00:38.596 → Connecting Wifi: FRITZ!Box 6591 Cable YR 2,4 GHz
16:00:38.632 → …
16:00:41.086 → WiFi connected
16:00:41.086 → IP address:
16:00:41.124 → 192.nn.nnn.nnn
16:00:41.124 → Connect failed: -1
The IP address has been blinded by me.
The display of the ESP32 shows " connecting…" and is freezes.
Can anybody help how to proceed?

Does

Hey there, I had the same Problem. Apparently they changed the HTTPClientSecure Library recently. You have to insert following line

client.setInsecure();

Before calling the HTTPclient.
For your reference: Latest Core Breaks WiFiClientSecure Insecure HTTPS · Issue #4992 · espressif/arduino-esp32 · GitHub

I'm not Sure, if I understood correctly. I'm a Bit confused. Ist there an issue between the serial port of the Macbook and ESP32…?
Seems that I have to insert client.Setinsecure() Info the Script. However I'm not able to upload any script because in the IDE no serial port is shown.
Are German? If yes, we can continue in mother tongue.
Best wishes
Adi

Yes, I'm also German, so I'll talk in German:

Das ist komisch, sollte aber mit dem obigen Fehler nichts zu tun haben. Nachdem es bei dir bereits mindestens ein Mal geklappt hat, würde ich empfehlen erst mal alles aus- und wieder einzustecken. Ansonsten könnte es an fehlenden Treibern liegen

Eben, war auch mein Gedanke. Treiber von Silikon Land ist erfolgreich installiert. Ich habe noch ein älteres Windows Notebook rumliegen und werde versuchen, ob der D1 Mini über den serial Port in der Windows-Welt funktioniert.
Das eigenartige ist, dass alle anderen Boards mit dem MacBook M1 problemlos funktionieren. Nur der D1 Mini zickt. Am D1 Board kann es eigentlich auch nicht liegen.
Ich habe den D1 Mini zusammen mit einem 2,4" TFT und dem Testprogramm "keylock" von AZ-delivery erfolgreich getestet. Allerdings wird das Testprogramm nicht als Sketch über den serial Port hochgeladen sondern als *.bin Datei.
Vmtl doch ein Treiber Problem?

Moment, ich dachte wir reden vom ESP32. Der D1 Mini ist ein Board der ESP8266 Familie. Da musst du zurück in den Boardmanager.

Sorry mein Fehler. Ich bin noch neu im Thema und verwechsele gelegentlich die Bezeichnungen.
Im Board-Manager habe ich den D1 Mini als Board natürlich ausgewählt. Kann aber sein, dass ich dort doch das falsche Board gewählt habe. Läuft wohl auf ein Try& Error hinaus bis zum Try&Hurray. Es gibt ja diverse Clone. Es ist auch kein echter Wemos D1 Mini sondern ein kompatibler.

Ah ich verstehe. Kein Problem. Als Tipp würde ich dir mitgeben, dass du das Projekt vielleicht doch lieber als Anfänger auf dem ESP32 versuchst. Beim D1 Mini kann es sein, dass du den Code abändern oder andere Bibliotheken verwenden musst. Wenn du den Code sowieso schon einmal auf den ESP32 geladen hast, sollte es ja gehen.
Aber dann viel Erfolg und das bekommst du schon hin : )

Danke für die Wünsche.
Alles Gute
Adi