Invalid device signature Attiny 85. Correct wiring

I use Arduino Nano as programmer and I have absolutely no problems with Attiny 85 that I bought from Digikey.
I have a couple of Attiny 85 that I bought from Aliexpress that I can’t program. When I try to program them I get this message:

  1. avrdude: Yikes! Invalid device signature.
  2. Double check connections and try again, or use -F to override this check.

I tried to burn bootlogger and I also tried an external clock with 85 but I got the same message.
Once I replace Aliexperss 85 with the one that one that I got from Digikey everything works like charm.

Did you burn the boot loader into your new chips? Only needs doing once to set the speed flags.

Otherwise it sounds like you got ripped off, and got fake chips.

Post the FULL error, not just part of it!

On one occasion I received some AT85 where the reset was disabled. I could only revive them by building a HV programmer to unbrick them.

As a side-note: If the AT85 is clocked at 1MHz (factory default) it may not respond to a fast programmer. I use the USBASP programmer and then I need to select the slow speed programming mode to set the speed to 8 or 16MHz, after which it becomes responsive to a fast programmer.

A while back I stopped to buy MCU's from Aliexpress, as the amount of fakes I received did not justify the little price difference anymore. I even received ATTiny13 that were completely different 8pin chips with a fake marking.

No. It stated in post.

There is only one more line which depends on what I'm doing. If I try to burn bootloader I'm getting the following message:
avrdude: Yikes! Invalid device signature.

  • Double check connections and try again, or use -F to override this check.
    *Error while burning bootloader.

i agree it does not make much sense to buy chips on ALi or e bay and I ordered some from Mouser but I was thinking that while I'm waiting I will try to program them as I already got them.