IOT Cloud - Code Upload Times out

Starting today, upload is timing out every time I try to upload to either of my two MKR1000s. Verbose error text attached. Message in red above the error window “Reset before upload: 1200bps Touch: Open port COM8: Invalid serial port.”

Environment:

  • Windows 10
  • Using the Arduino IoT Cloud Web Editor
  • Boards: Arduino MKR1000. I have get the same symptoms with both. One is straight out of the box and I haven’t even added the connector pins
  • Script: For troubleshooting, I’m just using the Examples/blink.ino app

Troubleshooting I’ve done so far:

  • Rebooting
  • Stopping and restarting, reinstalling Arduino Create Agent
  • Switching USB cables (I’ve tried four)
  • Switching boards: To make sure it wasn’t a USB issue, I switched boards to a Nano. Using the same Web Editor set up (but different USB cable) I am able to load the blinker app to the Nano
  • Trying to upload from the desktop IDE (similar timeout issue)
  • Communicate with the boards. From the desktop IDE, I am able to get board information from each MKR1000 through the option on the Tools menu (e.g., serial number)
  • Gone back to the Device page, deleted the devices and tried to reinstall. The page can see the boards so that I can start the configuration, but then times out in a way similar to this issue (https://forum.arduino.cc/index.php?topic=713707.0). Then after a long pause it gives an error page “We were not able to configure the Secure Element” with this additional note: Reset before upload: 1200bps Touch: Open port COM8: Invalid serial port. On retrying, sometimes the message will read, “…Serial port busy”.

error.txt (8.96 KB)

Hello @wmurphy41,

since the issue happens even using the Desktop IDE, looks like something related to your board/PC/OS.

Can you please try to put the board in bootloader mode (double tap on the reset button, until the led "breathe") and try again?

Thanks. That worked for both boards first time. I've learned a new trick.