IoT cloud doesn`t work

Cant understand what is going on... My arduino nano 33 IoT worked well a long time and my projects was running flawlessly for weeks, but suddenly everything stopped working. I really cant do anything with IoT cloud. Cant update WiFiNINA (doesnt work via arduino IDE either) and Im not able to add my arduini nano rp2040 connect to the IoT cloud either. I tried to delete devices and add them again and that I can do but then the boards wont go online, just says: ready to connect. So frustrating... Can anyone help?

I guess there was something wrong with IoT cloud cause it didn`t matter what I tried to do, but then suddenly day after I gave up my project started working again...

I do also experience similar issues... very often I need to reinstall sketch or sometimes wait one day and test again to get all working again... right now as I am writing it works fine

@ruostee66 Did you manage to get your NINA firmware upgraded? The latest version has many improvements in terms of reliability, especially when it comes to reconnecting after network glitches

Yeah. I managed to do it via IDE. Cloud didnt work after for awhile that, but now suddenly it works again, although its not still as stable as I hoped it to be. Cool platform, but needs to be more stable.

There's a lot of ongoing work to make all layers more robust, so please keep providing feedback because we're iterating quickly :pray:

1 Like