IOT CLOUD e board di terze parti ESP8266 ed altri

salve,
il problema è che non riesco ad associare una board di terze parti (nodemcu, wemos.., esp32..) Ad un progetto che ho già testato con successo con dispositivi originali Arduino.
Questo succede solo nella modalità IOT CLOUD, mentre in modalità WEB non ci sono problemi, riesco a compilare e caricare il progetto senza difficoltà.
qualcuno sa dirmi se ci sono impedimenti relativi a questa modalità?

Prima di scrivere questo post ho seguito tutti i tutorial sia Arduino che YOUTUBE, ho provato in windows e linux senza risultato: la COM è totalmente inesistente.
Ho realizzato con successo un progetto che comprende due BME280 ed un NANO RP2040.
funziona tutto perfettamente, sono molto soddisfatto anche della DASHBOARD.
Ho però la necessità di utilizzare un una board piu piccolo ed ho scelto una WEMOS...R1.
In un tutorial viene menzionato che la COM deve essere definita anche nell'ambiente IOT CLOUD, ma non ne trovo la strada per farlo.

qualcuno mi può aiutare ?

Ho anche acquistato un plan nella speranza che fossero limitazioni destinate alla versione free, ma senza successo.
Grazie fin da ora, saluti a tutti .
D

[RISOLTO] ho ripetuto il passaggio in WEB EDITOR (per l'ennesima volta) e questa volta ha funzionato .
quindi : definite le variabili, ho completato e vericato lo sketch ho ciccato su "</> Open full editor", ho ricompilato e caricato il progetto , poi sono tornato nell'IOT EDITOR ed ho definito la dashboard.
It works
ciau
D