IP not getting set on Ethernet Shield

I just brought an Arduino Ethernet Shield . I was trying to connect the Ethernet Shield to my University’s LAN network .
So I set the ip,mac,subnet mask and gateway as required.
But now when I print the LocalIP on the serial monitor I get 0.0.0.0
I also tried to ping the Ethernet’s IP with my laptop and it was saying :Destination Host unreachable.
I have also attached the ping screenshot.
Can anyone tell me what the problem might be?
Any help will be greatly appreciated :slight_smile:

ping.png

It appears the SPI connection from the Arduino to the ethernet shield is not working. Insure all the ethernet shield pins are inserted into the Arduino fully. The ICSP pins are the SPI data lines for the ethernet shield, so check them extra close.

I checked the ICSP pins and all other pins as well. After making sure all of them are connected well I tried again but the same thing happens. :( Can there be some other cause?

Also I just now tried to connect the ethernet shield with my computer to create a local connection. In this case also I couldn't ping . I read in some blogs that a crossover cable is necessary for connecting computer with the shield and I'm using standard LAN cable (cat5). Is crossover cable necessary while connecting with my computer?

The w5100 has a crossover ethernet port, so the crossover cable is not necessary.

The big problem is the lack of SPI communication. Your Arduino is not communicating with the w5100, or it would have returned the correct ip, and not 0.0.0.0.

Are you sure the shield is using the Wiznet w5100, and not the ENC28J60? If you post a link to the page from which you purchased it, that may help.

So I set the ip,mac,subnet mask and gateway as required.

This would be the first time "as required" and "correctly" were not the same thing. Post your code.