IR and Timer1 library conflict - SOLVED

I have a project using Timer1 library and it works okay.

I have a test project using IRRemote (and also tried with IRLib) for receiving IR signals which works fine.

When I integrate IR library with the main Timer1 project the IR codes are no longer received properly (all translate to 0x0 or 0xffffffff values).

Commenting out the Timer1.initialize function makes the IR code work again... but the rest of the project is useless without the Timer1...

Its for a Nano so I only have Timer0, 1 and 2 to play with. I thought IR library was on timer 2 so would not clash with timer 1 but I think I may be mistaken.

Any suggestions to alternative code for the IR part to allow user input (I really do not like the idea of reworking the main code). I cannot operate connected to the serial port and have very little physical space (or pins) for a button type interface...

Help please I'm running out of ideas!



It was because I had a timer interrupt which was running in the middle of the reading process. Kill the interrupt and its working again.

So now I know... I have to rework the main code to manage the interrupt...hey ho