IRremote library fatal error avr/interrupt.h: No such file or directory

Hi All,
I am new to Arduino.
I tried to test out the IRremote example from the RobotIRremote\IRrecvDemo.
It won't compile as it gave me this error:

/Applications/Arduino.app/Contents/Resources/Java/libraries/RobotIRremote/IRremote.cpp:23: fatal error: avr/interrupt.h: No such file or directory
compilation terminated.

Can anyone help?

[Environment]
Mac OS X 10.9
Arduino v1.54

Only the DUE and the Micro need 1.5+. Try installing 1.0.5, instead.

Hi PaulS,
Thanks! I will give it a try this weekend.

I found this blogger maintains the IRremote library here:

I tried to copy the original IRremote library to v1.54 and use it, but I still got the same error.

Do you know Is there any difference in the IRremote library in v1.05 & v1.54?
or only v1.05 will work?

Thanks for your reply!

If you post the code you are trying to compile, I can test it on 1.0.5.

Hi PaulS,
I have removed the library I downloaded from the IRremote blog and restore the default RobotIRremote library.
Still got the same error. The code sample below was directly from Arduino v1.5.4, nothing has changed.

Thank you for your help! :slight_smile:

#include <IRremote.h>
int RECV_PIN = 11;
IRrecv irrecv(RECV_PIN);
decode_results results;

void setup()
{
  Serial.begin(9600);
  irrecv.enableIRIn(); // Start the receiver
}

void loop() {
  if (irrecv.decode(&results)) {
    Serial.println(results.value, HEX);
    irrecv.resume(); // Receive the next value
  }
}

Hi,
I have installed Arduino v1.05 and no longer getting the error .
Thanks! :slight_smile:

Stonez