Is it possible that I killed my mkr1000?


So I have been working on my stuff and when I wanted to upload my sketch to my arduino it said “unable to upload becase nothing found on COM5” (or at least something like that. I tought it was a common thing because it happend a lot when I opened up 2 IDEs at the same time but then a simple restart helped but not now. I have connected a 7 segment display and a OLED display to monitor some data, but I double chacked everything so I didn’t mess up any of the wiring, even tho it was working for a day with this wiring until today when I uploaded my sketch. I didn’t tuch my wires and arduino, its just randomly stopped working. I did a research about that, a lot of people had same issues with windows not recognizing the arduino but in this case I updated every USB driver and still nothing. I have tried to connect it to my laptop and the issues was there as well, windows didn’t recognize, it was a “unknown USB connected”.
The green power on indicator led is on and sometimes the oramge lights up as well, so if I killed it I didn’t kill it fully but, I dont know.
Also, before it was not working the OLED display shown the adafruit logo even without any program, just as a “hey I am working” thing. Now it is not working either.

Did anyone met any kind of similar problem? Is there any solution or I killed it somehow?

activate the bootloader with double reset and upload a good sketch. the port will change in the process

Oh well, thank you so much. It worked.