Is my Arduino Burned ?

I was playing with Arduino by mistakenly I just plugged 5v to GND row and It.... I plugged it out in secs and It was little bit smelling When I tried t work with I pressed Reset but it wasn't working ! Then I tried to upload my codes I go this error Guys please help me out ! :'(

Arduino: 1.6.13 (Windows 10), Board: "Arduino Nano, ATmega328"

Sketch uses 928 bytes (3%) of program storage space. Maximum is 30,720 bytes. Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes. avrdude: ser_open(): can't open device "\.\COM3": The system cannot find the file specified.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

I saw one more thing when I used to plug my Arduino Nano In the Device Manger the CH340G would appear in the COM ports !

(deleted)

It isn't getting detected and I noticed my CH340G was smelling !

(deleted)

One more thing I programmed it to behave as a voltage meter and I was saying it send data to my PC Now when I plug it with a battery first the tx and led get really high for a sec and then tx stays on for sometime then it stops and then the led starts blinking very fast and after a few secs it gets dim and when I plug it in for about 1min or less it gets detected on the com list of device manager and then dissappears

@Sagnik2, please do not cross-post. Other thread removed.