Is my Arduino duemilanove broken?


I've been working quite a while with an Arduino Duemilanove. When I tried a new circuit last week by mistake I connected a voltage of 12 Volts to a pin which was configured as "read". Since then I am having problems with the Duemilanove.
I cant upload sketches:
avrdude: avrdude stk500_getsync() not in sync resp=0x00;
pressing shift while uploading: usbdev_open(): did not find any USB device "usb"

The reset button doesn't work.

I can't upload the bootloader:
usbdev_open(): did not find any USB device "usb"

I already tried different versions of Arduino software. I uninstalled the driver and installed it again.
I even bought a new microcontroller (ATMEGA 328) and replaced the old one. But nothing seems to help.
The right board is selected and also the right com-port.

Is there any possibility to get my Duemilanove running again or is it completely broken?

The 12V probably damaged also other components.
Can you measure the 5V ? If that is okay, you can perhaps use the ATmega328 with the ICSP header (if you have a programmer).
But it is best to get a new board. 12V is too much.