Is my Arduino fried?

I was testing a complex sketch on Arduino Uno which was working until I added a digital measurement of voltage across an external resistor to get the current. I use an external power supply of 12 V to power-up the circuit and a stepper down circuit for Arduino to give it 5 V. The ground is common. The voltage between the measured point and Arduino ground was 0,8 V (measured). The Arduino was plugged to the PC via USB. When I connected the 12 V power supply to 220V my PC shut down completely. I had to switch it on again with the power button. The Arduino does nothing now. If I try to load a sketch I get "avrdude: stk500_getsync(): not in sync: resp=0x00". The L led is on, the power led is on, TX and RX are off even if I try to load something on it. The serial monitor opens but is completely empty, nothing is received and if I try to send something the RX does not flash. I tried to replace the chip with a good one working on another project, nothing change, still the same. I am wondering about what else could be broken?