Is my Arduino Nano hopelessly dead?

Arduino Nano (Clone)
CH340 USB Driver chip

Im at the desperate stage here, this poor little Nano has been working flawlessly for a while now. It was connected to a circuit driving mosfets, with the usual separate power supply for the nano and high voltage side but with connected grounds. The circuit worked flawlessly before for a while. The nano then stopped responding.

I was unable to upload new code, so I disconnected the nano from the breadboard and rest of the circuit. Still unable to upload a simple blink sketch.(avrdude: stk500_getsync(): not in sync: resp=0x00)

Next steps

  • Restarted Arduino process

  • Restarted PC

  • Reinstalled CH340 Drivers (Windows does still recognise the Nano as a CH340 COM device, before and after driver reinstall)

  • Tried an identical clone Nano, works fine

  • Tried to re-flash boot-loader on Nano following tutorial on Using an UNO as a programmer.

Keep getting the Yikes! Invalid device signature 0x0000000, (sometimes 0x00ff00)
I triple checked the wiring to have it the same as the UNO-NANO diagram on the arduino isp webpage. Uploader ArduinoISP sketch to working UNO (programmer)
Tried a 10uF cap between RST and GND on programmer, I get "programmer is not available"
Tried to burn different boot-loaders, Atmega328p, Atmega328p (old bootloader), UNO bootloader.
Using Arduino as ISP as programmer.

Flashed the other identical clone Nano, burnt boot-loader fine.

Physical signs on the dead Nano.

  • No damage to all components on the Nano board
  • Power LED is the only LED that works when a usb is connected, no flashing of any other LEDs.
  • Multimeter says 5v on 5v pin, 3.3v on 3.3v pin
  • L Led blinks in sync with programmer L Led
  • TX and RX LED do not blink at all

Tried Loopback test(although some forums say it doesn't work on the CH340 chip) and it doesn't echo, but TX and RX pins lightly flicker on Enter key press in Serial Monitor.

Some posts suggest the oscillator is dead, I don't have a oscilloscope to diagnose this.

Could I have shorted out the oscillator.

Thanks in Advance

If the other Nano works fine for all these things, then it doesn't look good. What does the multimeter say about the voltage on the Nano's RST pin?

Constant 5v across the RST pin on the Nano

If Reset is ok, then I don't know what to suggest. These things are not really repairable.