Is my Arduino Uno board past saving?

My board is an Arduino Uno of unknown origin (I was passed this particular board to fix it but can't get more details on if its a clone board or not and where it was procured from).

On visual inspection there seems to be nothing wrong with the solder joints.

Plugged in with a known working USB cable (tested with other working Uno boards) and the right LEDs are lit with exception of Pin13 is not flashing (Its not a new board, so I assumed it was preloaded with a custom sketch).

Tried physical reset but its not showing any change. Computer (Win10) shows that the USB device is not recognised (checked with other working boards to rule out bad USB port) and tried updating the driver and it says its already on the best driver.

Now I did a swap of the Atmega chip with a known working chip, plugged in and I begin to see hope with the initially quick flashes of RX and TX LEDs apart from Pin13 and Power LED, but then it goes back to the same state as before and still with the "USB device not recognised" error.

Then I proceed to test the now swapped Atmega chip (from the subject board) to a known working Arduino Uno board, had an initial success with the COM port being recognised. Then I tried to upload the 'Blink' sketch and it gave a "avrdude: stk500_recv(): programmer is not responding." message. I had "verbose output" checked during uploading and notice that it dwells for a very long time with the last line showing "...4 more". This tells me that the Atmega chip is faulty as well.

Should I write off the board and call it a day or is there some workaround or fix that anyone had some success with?

Play with it as a learning experience. Bear in mind also that replacements can be very cheap, although delivery time may be long: Geekcreit® uno r3 atmega328p development board no cable geekcreit for arduino - products that work with official arduino boards Sale - Banggood.com

Arduino Uno consists of two main parts: a USB-UART converter and an Atmega328P microcontroller. USB-UART can be of several types and each needs its own driver.
First, give a good photo of your board to identify the type of its USB-UART.

Thanks for the replies guys. Yes I am experimenting with the board to learn as much as I can and its been a hoot so far. I've included the picture of said faulty board for reference. Unfortunaley, I'm a new user so I can only upload 1 at a time. Yes, the Atmega is purposely missing in the picture.


Here's a picture of the USB-UART(correct me if wrong) close up.

Can you program it using the ICSP interface ?

Coincidentally was just reading about it as a possible solution. If I got the gist correctly: Its a USB stick that have jumper cables that goes into the ICSP nodes on the board and detect it from there? If you happen to come across good material online, do link it here. To answer your question though, no I haven't tried it and its probably my next best course of action. I'll need to buy the USB programmer first of course.

You have a clone of Arduino Uno with 16u2 USB-UART bridge. It need the same driver as original Arduino Uno. You may reinstall your driver or try on another computer.

You can try another Arduino as ISP programmer Arduino as ISP and Arduino Bootloaders before to buy standalone programmer.

I did try on another computer before, same output.

If its the same driver, shouldn't it already work as I have the other working boards which I believe are original boards.

Anyway I'm searching for atmega16u2 drivers and google came up with several answers. Going to have a go at it and report my findings when I get the time.

If other boards work with the driver, then this board is faulty.

You can use a second board as a programmer for the busted one using ICSP

Or this:
https://www.arduino.cc/en/Hacking/DFUProgramming8U2