is my board broken?

I recently bought a Arduino Mega 2560.

Everything appeared to be working fine to start with, I managed to blink LED's and show temperature in the serial monitor etc.

The latest thing i have tried to do was to show text on an LCD. The Text was really dull even with the POT turned up and down.

Now when i connect my Arduino to the USB cable it does not show up in the Arduino software.

Mega 2560 is selected in the board options, but the port is blanked out, as if the pc cannot see the board.

I have tried different ports and the cable is brand new, and work to start with.

I have trioed pressing the Reset button which also does nto appear to work. I have tested the voltages on the power pins and they all seem fine. neither tx or rx LED illuminate but the power LED does.

Any ideas?



Have you given this a try ?

this will at least tell you if your TXing and RXing to the board

yeh sorry tried that, and neither rx/tx leds illuminated.

I decided it was the board so i have taken it back now. They didnt have any more in stock so i gotta wait for the new board to be delivered:(

If the screen was dull with the pot, it is very likely you wired the pot wrong and were shorting out the board. In which case, it was working correctly and shutting itself down.