Is my board fried?

I came this morning to see that my board isn't doing what it was programmed to do.
I tried to load on it a simple program that will simply open and close a relay I have but it doesn't do it. (the relay is working).

Here is a video on YouTube which shows lots of blinking but I didn't even program the 13 pin or L led.

Thank you

(deleted)

He probably is, and the Arduino can't supply that much current, and it's resetting the board making the LED blink.

(disclosure: I've not watched the video, I don't watch video)

The relay is powered by the Arduino but the current it open/close comes from somewhere else.
The relay was bought with the board. Can it really be that they don't fit?
It looks pretty much like the one in the picture attached.

Is there a way to bring it back to life or should I just throw it? I meant recycle!

5VhighLevelSingleRelay.jpg

(deleted)

I can't put on it new program!

I get this error-

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x85

Happens all the time. Unplug the arduino, save your sketch, close the arduino software, open it again, connect your arduino, choose correct board an port.

lg, couka

I wish it was so simple.
I have tried to do it on 3 different computers but it won't work.
Any other ideas?

Which operating system do you use?
If Windows: Does the arduino show up in the device manager, possibily as an unknown device?

lg, couka

The board appears as "Arduino Uno (COM3)"

Ok, then choose the right board and port in the tools menu of the arduino software.

lg, couka

You think I haven't done it????
It doesn't work.

I got error message -
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x85