Is my MKRFOX1200 Dead?

last week I've received my MKRFOX1200 Arduino and started working on my project. After a few successful Sketch uploads I cannot connect to my Arduino now. I'm not sure, however, if it's a software or hardware problem.

I've also had a problem with the power supply of my breadboard, so I'm really confused now.
So my status is now like this: I've tried connecting my MKRFOX1200 to different PCs, but none of them recognizes anything on the USB port. (I've checked different cables too)

However the PowerOn LED on the MKRFOX is glowing.

Is there any way how to find out, if my MKRFOX is really dead, or if there's possibly some way how to "resurect" it again? I found some info in the forums about possibly burnt USB/serial, but not sure how to check,if that could be my case.

Many thanks in advance for your hints.


I presume you tried the "quickly double tap the reset button" trick to put it into bootloader mode (will appear on a new com port).

If that works throw a very simple sketch at it to clear out the errant one eg. blink or bare minimum from examples.

If it doesnt work your PSU issue could have killed it.

Thanks for your reply.
I've tried the double-click reset, unfortunately no luck :frowning:
So the fact, that the power-on LED is glowing doesn't really mean anything, right?
I guess I have to order a new one :-/

The power LED simply means it is getting a voltage.
Whilst usually a good sign it can be misleading as LED's can light up over a range of voltages so even if its getting that there is no certainty that it is correct.

Do you have any other LED's lit of flashing ?
They tend to be more reliable as they only light up when the MCU tells it that it is doing something.

I have had similar problems getting the MKR FOX 1200 serial port to appear
I usually

  1. open the Control Panel > System > Device manager > Ports so I can watch the COM ports appear/disappear
  2. double cllick the reset button - after a few tries a COM port appears
  3. upload the Blink example code so I have a operational program

sometimes when compiling/uploading I have to double click the reset again
I have also found that the COM port can change after upload