Is my Nano 3.0 broken? cant run analogInOutSerial??

Hi, I'm very new to Arduino and I seem to be having a problem. I just wanted to make sure that the problem wasn't hardware related because it seems quite strange.

I am running an Arduino Nano 3.0 through USB. I have installed the ide and the drivers for the USB.
I then plug a 10k Pot into 5v to one side Gnd to the other and A0 to the middle signal lead(on the pot).
next I plug an led with resistor protection into pin D9.
then I open the ide and select AnalogInOutSerial from the examples, select my board(nano 3.0) from the tools menu, and click "upload"
the Arduino blinks for a while, then the IDE says "Done Uploading" no errors
I open the serial monitor and begin to play with the pot.
I get no output until I've turned the pot almost all the way up, then the led works but as expected, unfortunately once I do that, the serial monitor just shows 1023 for sensorValue and 255 for outputValue no matter what the position of the pot.
If I reset the board with the pot in any other position than all the way down serial monitor stays at 1023/255 if I turn it all the way down and reset the whole process starts over again,

not sure If what I'm doing wrong. I am running the example code with no alterations and I have set the IDE for the Nano 3.0 in the tools menu as well. I hope I'm just doing something stupid and I haven't wasted my $30USD =(

any help would be appreciated.

The setup sounds correct so my best guess is that the pot is flakey. Can you try a different one? How are the wires connected to the pot? Are they soldered?

I actually tried 3 but they were all on the same RadioShack electronics Lab... I am connecting the pot using the breadboard supplied on the lab.

Try just connecting a wire to A0 (hanging loose).

Run this sketch:

void setup ()
  Serial.begin (115200);

void loop ()
  Serial.println (analogRead (A0));
  delay (500);

Grab the end of the wire. I found that the more tightly I held mine the higher the number was. Then shove it into the Gnd pin and it should drop to 0 (in the monitor). Then touch the wire against the 5V pin and it should read 1023. That will prove your Nano works.

thank you I appreciate all your help. Unfortunately the arduino isn't giving me 0 at gnd or 1023 at 5 volts it is giving wildly variable number at each =( but hey at least I know now!

I tried the sketch again several times in order to test al the other pins and got the same result. Looks I'm off to buy another uController...

Seems odd they have all failed. Maybe a photo of your setup?