Is my WiFi dead? [SOLVED]

My wifi has quit working, if I press the button by the USB ports the blue light doesn’t light up and holding it for more than 30 seconds doesn’t get me the access point to connect to.

Have I killed it?

Any ideas on how to revive it?

Upload the yun serial terminal sketch, open the serial monitor and reset the ar9331 (white buttons near the led). Then paste the output

Here you go, I might be able to muck my way through this myself from here but any help or suggestions are much appreciated. Pasting it put it over the max message length for the forum and putting in one file was over the file size limit so it is in the four attached files, arrrrggghhhh!!!

I plugged in an ethernet cable and got

[  403.060000] eth1: link up (100Mbps/Full duplex)

I tried to run ifconfig to see what addresses it was using but the last thing I did before problems was to disable the console as mentioned in reply #5 in the “Tty for serial port to Arduino from Linino” thread which seems to have killed that possibility.

YunBootup1-75.txt (3.01 KB)

YunBootup75-125.txt (3.03 KB)

YunBootup125-180.txt (3.43 KB)

YunBootup180-end.txt (2.6 KB)

Well I did manage to muck through it.

Here is what I did: 1. had a f in the serial monitor waiting 2. reset the ar9331 3. hit send when it got to the failsafe mode prompt 4. ran mount_root 5. killed the serial monitor and started minicom on /dev/ttyACM0 6. copied /etc/inittab to /root 7. used vim to undo the console disabling ( I wasn't sure how this would go so I worked with a copy, probably unnecessary) 8. copied /root/inittab back to /etc/inittab 9. rebooted, Now the WiFi reset button works again.

I am learning OpenWrt, was starting to set up a WZR-HP-AG300H and got my home network all fsck up and the found out I couldn't find the Yun any where on the network and couldn't reset it. Know any place to find more understandable instructions on how to set up /etc/config/network on one of the beasts than the OpenWrt wiki? It's still all greek to me, I want to make the WZR and my Due into a "super Yun"

I'll post a warning on the Tty thread about needing the console link to use the wifi reset.

Thanks! Noble

Same thing just happened to me, but I haven't touched any of the boot settings. I just powercycled the Yún and it stopped working, so I decided to do a Wifi reset, but it no longer works.

Anyone know why this is happening?

Here's the end of what I get in the serial monitor (I can paste the rest if it helps):

[    5.290000] Error: Driver 'gpio-keys-polled' is already registered, aborting...
[    5.310000] scsi 0:0:0:0: Direct-Access     Multi    Flash Reader     1.00 PQ: 0 ANSI: 0
- preinit -
Press the [f] key and hit [enter] to enter failsafe mode
- regular preinit -
[    9.850000] jffs2: notice: (528) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 14 of xref (0 dead, 2 orphan) found.
[   11.130000] sd 0:0:0:0: [sda] Attached SCSI removable disk
switching to jffs2
- init -
[   31.630000] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000000
[   31.630000]

That is enough for me to tell you have a very different situation than I did, the earlier stuff in the boot log may give some hints as to what is wrong. The only thing I find on the OpenWrt wiki is an overfull JFFS2 can cause problems at this point, did you install a LOT of packages?

You should be able activate failsafe mode as I described but I am at a loss as to what you need to do in failsafe, you probably need someone more familiar with Linino's internals than me. Federico???

This is probably recoverable, you should have a serial console available on your USB port as long as the sketch is running and have telnet available at on the ethernet port which gives you access to fix things.

Good Luck

Yeah, it looks like that kind of problem. Have you installed something big? (php is big) If you can run in failsafe mode, you could be able to remove something big, reboot and have your yun back. Can you can run something like rm /usr/bin/php* (if you have installed php) and reboot?

Only thing I had installed was node.js.

I was able to run a reset-to-factory-anyway command and get it back, but it still doesn’t appear as if the reset button works…

Actually I take that back. It is resetting now, so that appeared to fix it. I guess I can't reliably run node.js on it. Too bad, was hoping I could...

Where have you found a nodejs package for openwrt?

I found it here:

Works like a charm and doesn't seem to take up much space.

Thank you!