Is there a Yun script that can be executed at boot to Sync time with Browser?

EDIT 20200301, Does ntp take a long time to sync?
I have a Rev2 arduino Yun I cannot get it to synchronize its clock when booting. I had it configured with SD card and a lot of software and realized this Time function isn’t working (again). Did a complete reset and start over. Yes I can synchronize with Browser using the Luci button “Sync with Browser”, but why not have that command embedded in a startup script like rc.local? ( I tried-see code below)
I have installed nearly every utility having to do with maintaining time as a client, but if one can’t get the OS (OpenWrt LEDE 17) on the right time the sketches will never have the right data points. I know I’ve heard ‘use a I2C clock chip’, bla, bla. but that does not help the browser or any utilities on the Linux side. I went through a lot of exercises to get my Rev0’s to sync in 2015, (not on my bench now), but this Rev2 has me baffled. I had thought maybe it was a wifi issue so all of this Time troubleshooting I am doing through the eth1 port, WIFI has a wrong password so it cannot connect. Looking in the system log, I can see that the wlan tries every two minutes to acquire but remains not connected. Then about an 45 minutes later after boot I see the time jumps to sync’ed state.
Below is a capture from the last terminal (Putty) window before Time synchronized again. I have internet access, can opkg update, install ntp client , SCP, SFTP, load sketches, etc.

Sat Feb 29 20:23:41 PST 2020
root@GYun:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=54 time=7.205 ms
64 bytes from 8.8.8.8: seq=1 ttl=54 time=7.257 ms
64 bytes from 8.8.8.8: seq=2 ttl=54 time=7.167 ms
64 bytes from 8.8.8.8: seq=3 ttl=54 time=7.209 ms
64 bytes from 8.8.8.8: seq=4 ttl=54 time=7.113 ms
^C
--- 8.8.8.8 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 7.113/7.190/7.257 ms
root@GYun:~# date
Sat Feb 29 20:24:19 PST 2020
root@GYun:~# date
Sat Feb 29 20:32:47 PST 2020
root@GYun:~# uci set system.ntp.enable=1
root@GYun:~# uci commit system
root@GYun:~# date
Sat Feb 29 20:37:08 PST 2020
root@GYun:~# /etc/init.d/sysntpd restart
root@GYun:~# date
Sat Feb 29 20:37:29 PST 2020
root@GYun:~#
/code]
Here it is still off by 10 minutes from Windows clock
I have tried a dozen ntp servers. no diff. Time is off by 5 to ten minutes depending on last power down interval. Occasionally I leave a sketch running, 30 minutes, I dunno, come back to the screen and ooops it sync'ed within a second of Windows. The rc.local script for the Yun (Its named GYun, my 7th.)
rc.local
[code]# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

boot-complete-notify

# added 20200224
ntpd -q -p 0.openwrt.pool.ntp.org

/etc/init.d/sysntpd restart

exit 0

TIME still not sync’ed. I’m not looking for exact - within a minute would be great.

The real issue here is in case of any power interruption somewhere unattended a remote YUN used as a monitor might never have the clock right. I have read several requests for solutions that seem unanswered by the developers as concrete remedies. Help?
To be clear is there a script that can be executed at boot that replaces the function of the click button “Sync with browser”???

After a lot of testing in the terminal (PuTTY): This an out-of-the-box configured Yun before the SD card is installed. . . . installed ntpdate Added these Google time.google.com IP addresses to the top of list of NTP server candidates in luci. These seem a lot more responsive and don't block successive requests. I tried three times - got responses every time. 216.239.35.4 216.239.35.8 216.239.35.12

In /etc/rc.local added ntpdate 216.239.35.12

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

boot-complete-notify

ntpdate 216.239.35.12

exit 0

Time seems to update in the system page within ten seconds of opening luci where I could wait for minutes or up to an hour. We will see.

BusyBox v1.28.3 () built-in shell (ash)

 _______                     ________        __
|       |.-----.-----.-----.|  |  |  |.----.|  |_
|   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
|_______||   __|_____|__|__||________||__|  |____|
         |__| W I R E L E S S   F R E E D O M
-----------------------------------------------------
LEDEYun 17.11, r6773+1-8dd3a6e
-----------------------------------------------------
root@GYun:~# ntpdate 216.239.35.12
1 Mar 11:28:36 ntpdate[4735]: adjust time server 216.239.35.12 offset -0.001466 sec
root@GYun:~# ntpdate 216.239.35.12
1 Mar 11:29:01 ntpdate[4826]: adjust time server 216.239.35.12 offset 0.000378 sec
root@GYun:~# ntpdate 216.239.35.4
1 Mar 11:29:11 ntpdate[4871]: adjust time server 216.239.35.4 offset 0.000123 sec
root@GYun:~# ntpdate 216.239.35.8
1 Mar 11:29:22 ntpdate[4916]: adjust time server 216.239.35.8 offset -0.000370 sec
root@GYun:~#