Is this MEGA 2560 R3 faulty?

I've been using Arduinos for years but recently bought (an official retail) Mega 2560 R3 for a bigger project. I'm using the 1.0.1 IDE on an XP SP3 box but cannot get the drivers (from the IDE's driver folder) to take (Windows says it cannot install them, code 28).

Some odd looking things jumped out and maybe someone with a 2560 R3 can confirm if mine is faulty (all my others are UNOs, Duel, etc). Note I tried the usual stuff, checked usbser.sys is the kosher one, cleaned old infs off - I don't think Windows is at fault since UNOs work fine on there.

In device manager, I see TWO "USB Device" entries and the device ids do not look right to me - at least according to the inf file.

The first entry has:

USB\Vid_2341&Pid_0042&Rev_0001&MI_00 USB\Vid_2341&Pid_0042&MI_00

The second entry has:

USB\Vid_2341&Pid_0042&Rev_0001&MI_01 USB\Vid_2341&Pid_0042&MI_01

But in the 2560 R3 inf file from the drivers folder it has this:

..DriverInstall, USB\Vid_2341&PID_0042

Note no Rev or MI suffix. My Mega is not sending those IDs to windows according to dev mgr. This explains why the inf won't take, there is no dev id match.

So.. if I edit the inf file to have additional entries for those ids, it does get further and tries to load them. In fact, one entry does show 'Arduino 2560 R3" instead of 'USB Device' and assigns a COM port - and looks happy, but the second "USB Device" entry still does not work. If I try to use the COM port assigned to the working entry, it still doesn't work.

So what gives here - why is this MEGA not sending the expected id string? Is it the firmware?

Another important point, if I use the IDE on my Mac, it works blooming fine... so the board seems OK... I can't help thinking its Windows but those device ids look wrong to me and the inf file should be getting further than it is.


The MI portion of the USB identifier indicates the device is advertising itself as a Multiple Interface device.

This does seem strange. It is acting like it might have been loaded with an alternate firmware on the 16u2.

If you feel adventurous you could try reload the usbserial firmware in the 16u2.

See here for more information:

Thanks Louis. Do you or anyone else know what device ids an official Mega 2560 R3 should be seen in device manager in XP? I'd just like to confirm mine are incorrect before I go back to the supplier.

Ta, Chris

What do the vid and pid show up as on the Mac?