ISP use - Arduino goes down when connecting RST

Hi,
this is my first post. I'm totally new to micro controllers (but have some education in electronics). Accidently got into this because I bricked my 3D printers mainboard and need to flash its bootloader. I really tried and googled a lot, so if my question is stupid, please forgive me - I did my best.

I'm trying to use an Arduino Micro to update the firmware on an USBASP.
I have followed several guides (there's none for the Micro, but I assume that's not the issue). I can flash the ISP software to the Arduino, but as soon as I should check connection (e.g. avrdude -C ../etc/avrdude.conf -c avrisp -P COMXX -b 19200 -p m8 -v) things get wrong (of course I've entered the right COM port).

In fact, the problem turns out to be that, as soon as I connect the USBASP to the Micro, the Micro's USB connection to the PC goes down.
Since the connection cable didn't work, I have tried to manually connect the two with a breadboard and doing so I found that (it's in fact the same as with the cable) the issue is the RST pin. As soon as I connect this one, the Micro goes down (I have connected 3 LEDs as recommended to follow the flashing process. Here the heartbeat LED goes off), Windows plays the USB-disconnect sound and logically the above command immediately tells me that the COM port can't be found.

If I don't connect the RST things stay normal, but the command above doesn't show connection to the USBASP.
If I short the self-programming jumper on the USBASP after the Micro is connected to the PC, it also doesn't go down, but also doesn't show a connection.

Would appreciate help. I'm fairly lost. Thanks!