Issue when using Serial with ESP8266

So today a package I got off from AliExpress arrived, this controller which has an ESP8266 integrated inside of it.

I tried to create a new project on it and it is kind-of working. I did the steps of adding ESP266 config JSON url in the preferences and installed ESP8266 compatible boards. I’ve setup mine for WeMos v1 but nothing really works properly (I tried almost all of them).

When I installed the blinking sketch it works, but when I try something with Serial, that’s a bit of an issue.

I tried this sketch:

void setup() {
  Serial.begin(9600);
}

void loop() {
  Serial.print("Woah");
}

And while uploading I got this:

Executable segment sizes:
IROM   : 231828          - code in flash         (default or ICACHE_FLASH_ATTR) 
IRAM   : 26900   / 32768 - code in IRAM          (ICACHE_RAM_ATTR, ISRs...) 
DATA   : 1252  )         - initialized variables (global, static) in RAM/HEAP 
RODATA : 696   ) / 81920 - constants             (global, static) in RAM/HEAP 
BSS    : 24928 )         - zeroed variables      (global, static) in RAM/HEAP 
Sketch uses 260676 bytes (24%) of program storage space. Maximum is 1044464 bytes.
Global variables use 26876 bytes (32%) of dynamic memory, leaving 55044 bytes for local variables. Maximum is 81920 bytes.
esptool.py v2.8
Serial port /dev/ttyUSB0
Connecting....
Chip is ESP8266EX
Features: WiFi
Crystal is 26MHz
MAC: a4:cf:12:bf:8f:3b
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 4MB
Compressed 264832 bytes to 193381...

Writing at 0x00000000... (8 %)
Writing at 0x00004000... (16 %)
Writing at 0x00008000... (25 %)
Writing at 0x0000c000... (33 %)
Writing at 0x00010000... (41 %)
Writing at 0x00014000... (50 %)
Writing at 0x00018000... (58 %)
Writing at 0x0001c000... (66 %)
Writing at 0x00020000... (75 %)
Writing at 0x00024000... (83 %)
Writing at 0x00028000... (91 %)
Writing at 0x0002c000... (100 %)
Wrote 264832 bytes (193381 compressed) at 0x00000000 in 17.1 seconds (effective 123.9 kbit/s)...
Hash of data verified.

Leaving...
Hard resetting via RTS pin...

Nothing out of the ordinary, but when I try to connect to the serial port:

Exception in thread "EventThread /dev/ttyUSB0" java.lang.NoSuchMethodError: java.nio.ByteBuffer.flip()Ljava/nio/ByteBuffer;
 at processing.app.Serial.serialEvent(Serial.java:185)
 at jssc.SerialPort$LinuxEventThread.run(SerialPort.java:1299)

Afterwards I opened vscode and opened the sketch and I get an error that the serial port module is underlined (in attachment).

Screenshot_2020-02-28_10-37-27.png

Looks like the issue is not because of the controller. I update the code to:

void setup() {
  Serial.begin(115200);
}

void loop() {
  Serial.println("Woah");
  delay(100);
}

Just so I can get a new line and some more delay and used:

screen /dev/ttyUSB0 115200 and I have the serial data written out.