Issue with COM port upload

Hi All, I tried uploading my script after double pressing the reset button, its works fine to the CPU reset stage then fails. What i think happens is the PC no longer recognise the mkrzero after the reset… snippet from verbose where it fails… any ideas how to fix this? running windows 10, IDE 1.8.9

Verify 39668 bytes of flash with checksum.
checksumBuffer(start_addr=0x2000, size=0x1000) = e464
checksumBuffer(start_addr=0x3000, size=0x1000) = 8b1f
checksumBuffer(start_addr=0x4000, size=0x1000) = 50eb
checksumBuffer(start_addr=0x5000, size=0x1000) = 6608
checksumBuffer(start_addr=0x6000, size=0x1000) = e91e
checksumBuffer(start_addr=0x7000, size=0x1000) = 2c45
checksumBuffer(start_addr=0x8000, size=0x1000) = a0a7
checksumBuffer(start_addr=0x9000, size=0x1000) = 5074
checksumBuffer(start_addr=0xa000, size=0x1000) = 3705
checksumBuffer(start_addr=0xb000, size=0xaf4) = a1f1
Verify successful
done in 0.036 seconds
CPU reset.
readWord(addr=0)=0x20007ffc
readWord(addr=0xe000ed00)=0x410cc601
readWord(addr=0x41002018)=0x10010305
writeWord(addr=0xe000ed0c,value=0x5fa0004)
Couldn't find a Board on the selected port. Check that you have the correct port selected.  If it is correct, try pressing the board's reset button after initiating the upload.
processing.app.SerialException: Error opening serial port 'COM5'.
at processing.app.Serial.<init>(Serial.java:147)
at processing.app.Serial.<init>(Serial.java:82)
at processing.app.SerialMonitor$4.<init>(SerialMonitor.java:101)
at processing.app.SerialMonitor.open(SerialMonitor.java:101)
at processing.app.AbstractMonitor.resume(AbstractMonitor.java:104)
at processing.app.Editor.resumeOrCloseSerialMonitor(Editor.java:2126)
at processing.app.Editor.access$1300(Editor.java:115)
at processing.app.Editor$UploadHandler.run(Editor.java:2104)
at java.lang.Thread.run(Thread.java:748)
Caused by: jssc.SerialPortException: Port name - COM5; Method name - openPort(); Exception type - Port not found.
at jssc.SerialPort.openPort(SerialPort.java:167)
at processing.app.Serial.<init>(Serial.java:136)
... 8 more
Error opening serial port 'COM5'.

Does the problem go away if you close all windows of the Arduino IDE, start the Arduino IDE again, and then upload again?