Issue with uploading sketches

I get the following error when trying to upload a sketch to my Nano. I had been working on this all morning and had no issues until all of a sudden it can't upload anymore. I restarted the PC, swapped cables. PC recognizes the device and is listed in my device manager. This error occurs on all Nanos I've tried (I've tried 3 other Nano's and sketches won't upload on those either. All board files are updated. Not sure what else to try here. Any thoughts would be appreciated. Oh I also tried uploading use the ATmega328P and the Old Bootloader, both fail.

Arduino: 1.8.15 (Windows 10), Board: "Arduino Nano, ATmega328P (Old Bootloader)"

C:\Program Files (x86)\Arduino_update\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino_update\hardware -hardware C:\Users\dpalacio\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino_update\tools-builder -tools C:\Program Files (x86)\Arduino_update\hardware\tools\avr -tools C:\Users\dpalacio\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino_update\libraries -libraries \teleflex.global.pvt\global\Home\Medical\NA\MOR\Home2\dpalacio\Arduino\libraries -fqbn=arduino:avr:nano:cpu=atmega328old -vid-pid=2341_0058 -ide-version=10815 -build-path C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640 -warnings=none -build-cache C:\Users\dpalacio\AppData\Local\Temp\arduino_cache_189321 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7 -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7 -prefs=runtime.tools.avrdude.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.arduinoOTA.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -verbose \teleflex.global.pvt\global\Home\Medical\NA\MOR\Home2\dpalacio\Arduino\analog_test\analog_test.ino

C:\Program Files (x86)\Arduino_update\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino_update\hardware -hardware C:\Users\dpalacio\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino_update\tools-builder -tools C:\Program Files (x86)\Arduino_update\hardware\tools\avr -tools C:\Users\dpalacio\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino_update\libraries -libraries \teleflex.global.pvt\global\Home\Medical\NA\MOR\Home2\dpalacio\Arduino\libraries -fqbn=arduino:avr:nano:cpu=atmega328old -vid-pid=2341_0058 -ide-version=10815 -build-path C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640 -warnings=none -build-cache C:\Users\dpalacio\AppData\Local\Temp\arduino_cache_189321 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7 -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7 -prefs=runtime.tools.avrdude.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.arduinoOTA.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -verbose \teleflex.global.pvt\global\Home\Medical\NA\MOR\Home2\dpalacio\Arduino\analog_test\analog_test.ino

Using board 'nano' from platform in folder: C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.8.3

Using core 'arduino' from platform in folder: C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.8.3

Detecting libraries used...

"C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10815 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.8.3\cores\arduino" "-IC:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.8.3\variants\eightanaloginputs" "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640\sketch\analog_test.ino.cpp" -o nul

Generating function prototypes...

"C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10815 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.8.3\cores\arduino" "-IC:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.8.3\variants\eightanaloginputs" "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640\sketch\analog_test.ino.cpp" -o "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640\preproc\ctags_target_for_gcc_minus_e.cpp"

"C:\Program Files (x86)\Arduino_update\tools-builder\ctags\5.8-arduino11/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640\preproc\ctags_target_for_gcc_minus_e.cpp"

Compiling sketch...

"C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10815 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR "-IC:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.8.3\cores\arduino" "-IC:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.8.3\variants\eightanaloginputs" "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640\sketch\analog_test.ino.cpp" -o "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640\sketch\analog_test.ino.cpp.o"

Compiling libraries...

Compiling core...

Using precompiled core: C:\Users\dpalacio\AppData\Local\Temp\arduino_cache_189321\core\core_arduino_avr_nano_cpu_atmega328old_6c7a5e344ea07451da30444c02d0ba25.a

Linking everything together...

"C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7/bin/avr-gcc" -w -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p -o "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640/analog_test.ino.elf" "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640\sketch\analog_test.ino.cpp.o" "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640/..\arduino_cache_189321\core\core_arduino_avr_nano_cpu_atmega328old_6c7a5e344ea07451da30444c02d0ba25.a" "-LC:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640" -lm

"C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7/bin/avr-objcopy" -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640/analog_test.ino.elf" "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640/analog_test.ino.eep"

"C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7/bin/avr-objcopy" -O ihex -R .eeprom "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640/analog_test.ino.elf" "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640/analog_test.ino.hex"

"C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\7.3.0-atmel3.6.1-arduino7/bin/avr-size" -A "C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640/analog_test.ino.elf"

Sketch uses 3704 bytes (12%) of program storage space. Maximum is 30720 bytes.

Global variables use 204 bytes (9%) of dynamic memory, leaving 1844 bytes for local variables. Maximum is 2048 bytes.

C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/bin/avrdude -CC:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf -v -patmega328p -carduino -PCOM10 -b57600 -D -Uflash:w:C:\Users\dpalacio\AppData\Local\Temp\arduino_build_707640/analog_test.ino.hex:i

avrdude: Version 6.3-20190619

     Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

     Copyright (c) 2007-2014 Joerg Wunsch



     System wide configuration file is "C:\Users\dpalacio\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf"



     Using Port                    : COM10

     Using Programmer              : arduino

     Overriding Baud Rate          : 57600

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x46

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x46

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x46

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x46

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x46

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x46

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x46

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x46

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x46

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x46

avrdude done. Thank you.

Problem uploading to board. See Upload – Arduino Help Center for suggestions.

Did you go to that link and try the suggestions?

Have you tried different (known good) USB cables?

Yes as mentioned I've already tried swapping cables and yes they were working. I did look at the links but weren't very helpful as I've tried the ideas detailed in them.

Remove any connections to pins 0 and 1 on your Arduino board. These pins are used for communication with your computer, including uploads. Connecting anything to these pins can interfere with uploads.

Make sure you have the correct board selected from the Arduino IDE's Tools > Board menu. Note that some boards have similar names, but are not interchangeable. Examples include "Arduino Nano" vs. "Arduino Nano Every" vs. "Arduino Nano IoT" vs "Arduino Nano 33 BLE" vs. "Arduino Nano RP2040 Connect".

Make sure you have selected the port of your Arduino board from the Arduino IDE's Tools > Port menu.

If you don’t know which port is your Arduino board, you can find it like this:

  1. Unplug your Arduino board from the computer.
  2. Select Tools > Port from the Arduino IDE's menus.
  3. Note the ports, if any, listed in the menu.
  4. Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  5. Plug your Arduino board into the computer.
  6. Select Tools > Port from the Arduino IDE's menus. - The new port listed in the menu is your Arduino board.

Note that having the wrong selection in the Arduino IDE's Tools > Processor menu will cause this sort of error. So even if you fixed whatever was the cause of the original upload error, if you changed this setting in the meantime then you will be getting the error from a new cause.

So my recommendation is to try each upload for both the Tools > Processor > ATmega328P and Tools > Processor > ATmega328P (Old Bootloader) settings until you have fixed the problem.

Yes I've done all this and still not working. I'm checking my PC to see if it's a PC issue.

Please try this:

  1. Connect the Arduino board to your computer with the USB cable.
  2. Press and release the button on the Arduino board that is marked "RESET".

Do you see the "L" LED blink immediately after you release the "RESET" button?