Issue with USB com port on Acer Windows 10 - Port Busy or Access Denied

Tryed to connect an Arduino in an Acer Switch 5 laptop but I can't:

  1. Upload sketch
    Arduino: 1.8.9 (Windows 10), Board: "Arduino/Genuino Uno"

Sketch uses 928 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: ser_open(): can't open device "\.\COM5": Access is denied.

  1. Open Serial monitor:
    Error opening serial port 'COM5'. (Port busy)

Tried already:

  • change cable
  • change arduinos
  • run arduino as administrator
  • reinstall drivers
  • run verbose (no clue)
  • use non-arduino drivers
  • change computer (that worked :wink:

The strange thing is that I am able to run "Board Info", that means communication is working.

The boards are working properly on other computers.
When loading sketches on other computer and using this one just for power supply, arduino is working fine, so it means it is not power shortage.

This computer has only two USB ports - one of them is USB-C.
I face no issues on connecting USB devices to the same computer but some months ago, I couldnt get to run an USB-C / RS232 adapter... getting the same Port Busy message.

Any clue?

BoardInfo.png

Make sure no other application has COM5 open. You can only have COM port open in one application at a time and if you try to have it open in two you get this "Access is denied" error. You'll need to either tell that application to close the port or else close the application.

If you can't find another application that might be using the port, try restarting your computer. Sometimes a glitch will cause a port to get stuck open and the restart solves this.

Tried already.

Couldn't find any application using the port with Process Explorer... (looking at "service" key)
Tried also to change port number...
nothing...