Issues installing Arduino Uno Drivers

I recently purchased an Arduino Uno R3 Starter kit off Amazon and am having trouble updating the drivers.

I am currently working on a computer running windows 8 and have already disabled driver signature enforcement, so I should be able to install any driver with out any issues.

First a little History:

  1. This afternoon I attempted to install the drivers onto my laptop using a friend’s Uno R3.
    While in the device manager, the device appeared as Ardunio Uno (or something similar). Due to some restrictions with driver installation on windows 8, I could not update the drivers at that time. I could however, easily locate the driver and it appeared as a valid driver.

  2. Later on today, I received my package from Amazon and immediately disabled driver signature enforcement and tried to update the drivers using my own Uno. However, the device now appears as atmega16u2 DFU (as opposed to Arduino) and when I attempt to update the drivers (using the same exact method that I tried earlier today, in the same folder containing the drivers all downloaded from, the drivers cannot be located, although the PC realizes that there ARE drivers in the selected folder.

Any help that anyone could provide would be awesome!



PS I attached some photos displaying the issue.

Arduino Help Request Photo 2.JPG

Arduino Help Request Photo 3.JPG

See this post for DFU mode:,141407.msg1062815.html#msg1062815

The short answer is that if your 16U2 came un-programmed, there is a good chance the main processor is un-programmed as well. So even if you are able to reprogram the 16U2, you still need to figure out a way to program the 328.

I would send it back and see if you can get a replacement.

I appreciate the input, thanks!