issues putting XBee to sleep and sampling

Hi,
I’m putting together a simple sensor network for monitoring temperature. When running “router AT” on the sensing XBees, everything works fine. Now I’m trying to use the sleep mode so I can run on batteries. I follow the instructions from page 168 in the sensor network book: I use the End Device AT firmware and below are the commands to double-check the configuration (I want to sample every 5 seconds).

Here are the issues I have:

  1. the XBee doesn’t seem to go to sleep much; I have LEDs on pin 13 and 15 and both are mostly on (it seems they are on for 5 seconds and then briefly turn off)
  2. I’m getting each measurement twice (ie, two measurements every 5 seconds)
  3. when I run this for a few hours, I sometimes don’t get any measurements for 30 - 40 seconds and then start getting them periodically again.

Any thoughts?

According to the XBee manual, I don’t need to set IR when sleeping (it should always sample when it wakes up), but when I set IR to 0, I don’t get any samples.

Thanks,
Peter

+++OK
atsm
4
atir
1388
atsp
1F4
atst
14
atd0
2
atd1
2
atdh
0
atdl
0
atid
73
atwr
OK