Issues Self-Building Arduino

Hello, I am trying to self-compile the Arduino IDE from the source code.

I am following this guide here:

I have done everything as written, including adding the JAVA and ANT paths. I am able to do the ant dist and have the Arduino program build successfully. My issue is after it has successfully built, I click on the zipped final product (v1.8.15) and extract it to my desktop. However, when I click the arduino application, the Arduino logo pops up for about a second and then goes away and the program does not start. I tried click on the arduino debug application as well but it also causes the command line to pop up for a split second before dissapearing.

Can anyone help?

You should run the arduino_debug.exe from the command line. That should print a lot of output that may contain a clue to the cause of the failed startup. The terminal will stay open, which will allow you to read it.

If you post the output here, I'll take a look and see if I can spot anything.

Have you tried starting the production distribution of the Arduino IDE on your computer? If so, did it start up successfully? This would provide an indication about whether the issue is specific to your build, or whether it's a general problem with the system. The IDE must create or load files from the external sketchbook and data (i.e., Arduino15) folders on startup and usually the cause of the IDE not starting up is something about those external folders that breaks it.