Issues with USBasp...

Hi everyone,

I am having nothing but headaches trying to make my USBasp work on my new computer. It works fine on my old Windows 8 laptop but I cannot get it to perform at all on Windows 10.

I have tried many suggestions on forums but nothing so far has worked. I have used Zadig to install the latest drivers (libusb-win32 v1.2.6.0). I have totally uninstalled all old drivers and done a fresh re-install of Arduino IDE. Windows recognizes the USBasp when plugged in but I get this error message:

avrdude: warning: cannot set sck period. please check for usbasp firmware update.
avrdude: error: program enable: target doesn't answer. 1
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

the selected serial port
does not exist or your board is not connected

I don't know what to do about this, any help greatly appreciated

-Nathan

Install the libusbK driver using Zadig instead of libusb-win32.

Thanks Pert, I'll try that now

Pert, tried installing libusbk on Zadig, but the same error occurs. Restarted computer and no change...

Not really solved, but went out and bought a different brand and it works with this computer.

IME that error usually indicates that the USBAsp is working fine, but connections to the target are wrong (and that the problem is not a missing clock source, which gets slightly further into the process)... could there have been a connection problem that was incidentally fixed when switching to the second usbasp?

I checked the connections multiple times with the mulitmeter and they were all good... It's weird as it works fine on my old computer...