ist mein Arduino tot?

Moin,

nun wollte ich endlich weiter an kleinen Hardwareexperimenten spielen und will das nächste Programm aufspielen, da fragt mich die Arduino IDE nach dem COM Port. Hähh, das war doch COM 9 und auch in Arduino eingerichtet? Im Geräte Manager ist aber kein COM 9 nur ein COM 1 der ist es aber nicht, der ist immer da.

Also Arduino abgezogen und neu angesteckt. Meldung von Windows 7: Usb Gerät nicht erkannt ... =( Watt is nu los?

Gleiches USB Kabel an anderem USB Port - gleiches Ergebnis. Ich hab seid dem letzten mal nix gemacht - zumindest kann ich mich nicht daran erinnern.

Ich teste das jetzt gleich noch an meinem Laptop.

Ich bilde mir ein, das außer der Power LED auf dem Arduino nach dem einstecken die kleine LED an Port 13 einmal kurz geblinkt hat. Das tut sie jetzt nicht mehr.

Was kann ich jetzt noch tun?

Ich hätte hier noch ein STK500 Board, wenn das zu Diagnosezwecken hilft.

Martin

So, am Laptop das gleiche. Der Laptop hatte den Arduino noch nie gesehen. Nach dem anstecken: USB-Gerät wurde nicht erkannt.

Im Geräte Manager von Windows 7 steht unknown Device mit nem gelbe Ausrufezeichen. Von Hand nachinstalieren der Treiber aus dem driver verzeichnis von Arduino bringt dann die Meldung: Die Treibersoftware für das Gerät ist auf dem neusten Stand. Unknown Device.

Was ist denn jetzt los?

Wenn wir wuessten welchen der *uinos du hast...

Sollte es ein uno sein, dann koenntest du mal versuchen dessen usb-converter firmware neu zu uebertragen. Das ding hat einen eigenen bootloader. Dazu muss man irgendwelche pins verbinden, das habe ich im forum schonmal gelesen.

Vielleicht ist er aber auch einfach nur verreckt.

Ohhh .... sorry, ja es ist ein UNO ... hatte ich im Eifer des Gefechtes vergessen.

Ich such mal was zu dem USB Converter, oder hat da jemand einen Link?

Und was meinst du mit verrekt? Müll? Dann wäre das ein teurer Spaß gewesen :-(

Sowas passiert... den usb converter chip kann mann zur not zwar tauschen, aber wenn du das nicht selbst kannst / bekannte(r), dann ist der zeitaufwand unbezahlbar.

Daher kaufe ich nur noch billig(ere) spar-versionen ohne den usb kram oder strebe nach marke eigenbau und verwende getrennte usb-adapter / isp programmierer. Somit verreckt nicht immer alles gleichzeitig. Mein alter Diecimila lebt allerdings immer noch ;-)

Z.B. bei watterott gibt es ja genug alternativen.

Erzähl uns mal was Du gemacht hast, bevor Dein Computer nichts mehr vom Arduino wissen wollte. Grüße Uwe

Um auf deine PM zu antworten:

Hier der link zum firmware aufspielen fuer den UNO usb chip: http://arduino.cc/en/Hacking/DFUProgramming8U2

Wenn das nicht funktioniert, dann ist zumindest mal dieser chip hinueber. Der rest kann noch funktionieren.

Arduino UNO alternativen: wie sand am meer!

Das absolute minimum ist folgendes:

  • ein USB-serial adapter (im idealfall basierend auf FTDI chip, funktioniert bisher am zuverlaessigsten), maximal um die 15€. Die billigen ebay alternativen basierend auf CP_irgendwas haben meist andere pin-belegung und koennen aerger bereiten.

  • ein *duino board mit passendem anschluss oder adapter-kabel im eigenbau

Ich empfehle dir mal folgende seiten in ruhe nach arduino varianten durchzuforsten und zu sortieren was dir nuetzlich / verwendbar erscheint. Manche haben auch distributoren in DE.

www.adafruit.com www.sparkfun.com shop.moderndevice.com www.seeedstudio.com www.iteadstudio.com www.elecfreaks.com

Falls sich dein UNO nicht wiederbeleben laesst, gibt es genug guenstigere alternativen.

uwefed:
Erzähl uns mal was Du gemacht hast, bevor Dein Computer nichts mehr vom Arduino wissen wollte.
Grüße Uwe

Tja, wenn ich das so genau wüsste.

Ich hab vor ein paar Tagen mit den 7 Segment Anzeigen und dem MAX rumgespielt. Danach hab ich dann aber noch mal das Thema PullUp/PullDown Wiederstände nachgebastelt. Die Sachen haben auch alle funktioniert. Die letzten Tage war der Arduino immer per USB angeschlossen - ich hatte aber keine Zeit was zu machen. Heute wollte ich dann ein neues Programm übertragen und bekam die Fehlermeldung :frowning:

Martin

Hast du das anschlusskabel schon mal ausgetauscht? Zwr unwahrscheinlich - aber immernoch stressfreier als die Firmware des USB-Converters zu flashen oder ihn gar zu tauschen.

2 Rechner, 2 Kabel - überall das gleiche. Der scheint dann wohl hin zu sein …

Hi,

bei mir lag es am USB-Kabel. Obwohl ich das schon immer benutzt hatte, ging es einfach nicht mehr. Ich habe nicht rumgschnipselt oder eingeklemmt oder sonst was. Evtl China-Schrott. Keine Ahnung.

Grüße Mio

Ich denke mal, nach 5 Jahren wird es der Threatstarter, notfalls mit nem neuen Arduino, hinbekommen haben :wink: