It compiles, but won't upload

I am using the bare minimum project, and this is what it says:
An error occurred while uploading the sketch
Error opening serial port 'COM3'. (Port busy)
An error occurred while uploading the sketch

The 'COM3' is the port for the Arduino Uno which is what I am using.

I've tried to reload Arduino multiple times but it won't change.

What OS?
What version of Arduino IDE?
Which Uno? Please link the listing you purchased it from and/or a detailed picture. A lot are clones with a CH340 instead of the 16u2, this requires another driver.

If you remove the USB cable and the selection COM3 still appears as a valid choice in the Arduino IDE then it is likely that COM3 belongs to something else.

You need to provide useful details as @er_name_not_found listed.

Adding to previous replies:

  1. That means that something else is using the port. It can be another application or a pending upload.
  2. Does the problem still show after a reboot of the PC.
  3. What does Windows device manager say?

I have sometimes more than 1 instance (not extra windows of the same instance) of the IDE running. Having the serial monitor open in one instance, will cause the error in another instance.

OS: Windows 10
Arduino IDE: 1.8.16
I'm using en Elegoo UNO, it worked perfectly in the past. It just stopped working today.
When I open the Serial monitor it crashes.

Have you restarted your PC recently?
Are you using the same USB cable?
Can you try a different cable?