it should be more obvious that toInt() returns long

At: https://www.arduino.cc/en/Reference/StringToInt

It does say that it returns a long, but I wish the description wording earlier were clearer:

Converts a valid String to an integer.

would be better if it said

Converts a valid String to a long integer.

but I wish the description wording earlier were clearer

Why is the function called toInt(), when that is not what it does? toLong() would be a far better name.