IteadStudio IBoard Pro RTC problem

Dear Friends,

I would like to ask your help regarding this RTC problem on my new IBoard Pro made by Itead Studio.
Asking directly to them took months and still NO answer.

My problem is when RTC battery attached to the board, the time/RTC is error and it is not running.
This is what I’ve got on the serial window:

RTC is NOT running!
2165/165/165 165:165:85

But when I remove the battery, the time is fine, update and incrementing (as long power connected to the board only).

I quote earlier post on Itead studio forum about removing 1M resistor near the x-tal clock.
" please connect 0R between the crystal and the 1M resistor, and remove the 1M resistor."

Since the X-tal has two 1M resistors on each leg and my board (version unknown?) have 0 R unconnected, Do you know what should I do to fix this bug??

Thank you for any help,


IBoard RTC.jpg

Same problem here with 12 iBoard !!! No when RTC running on battery. Tried to interpret the spaghetti explanation given by ITAD mentioned in your post but no success. First removed the component attached to the x-tal leg closer to the processor, no change, then removed the second component, no change either. Both component do not appear to be resistors so I not sure they are the mentioned 1M components, anyway, still nothing. Strange also to me that the Vcc leg of the DS1307 is not connected to anything and the DS1307 appears to be running on parasitic current from pins 20 & 21. Strange also if you touch the Vcc Battery leg the DS stops working immediately, like we are drawing the very few amps it might have to far no word from ITAD either.

Hi macedo123,

I have suggestion from Mathias (look to his links on Itead Forum) to use FOCA USB adapter and switch power to 5V option to make this board’s RTC work.
My board still didn’t work out. My PCB version is 1.1.
BTW, Mathias also suggest me to contact them directly regarding this matter, do you want to try? :wink:

RTC error.png